teamviewer.com link icon
or
Ask The Community

TV12 Stuck on 'initializing display parameters'

Heya,

I use Teamviewer daily to support staff remotely. They are all on Windows 10, I'm on Mac OSX.

For the past 2 weeks or so whenever I want to access one of their physical machines or virtual machines Teamviewer gets stuck on  'initializing display parameters' and then just closes the window after a minute. Sometimes it work again, but this non-connection issue can go on for hours. It has gotten to the point that it is impossible to work like this anymore.

I have already uninstalled TV12 and reinstalled, but no change. Does anyone have a clue what's going on here?


thanks

Answers

  • Esther
    Esther Posts: 3,614 Community Manager 🌍

    Hi @LuSM

    This message can have several causes.

    One -most of the time- bulletproof solution is to restart the TeamViewer service on both sides of the connection: Our moderator @JeanK once created a helpful gif for the restart on WIndows:

    Maybe you can try this for the WIndows side of the connection as you already made a reinstall on your mac, right?

    Community Manager
  • LuSM
    LuSM Posts: 2 ✭✭

    Hi,

    As this was affecting all windows machines on the network, it was not related to a single Windows machine.

    The issue was identified though as a rough smart-switch a staff member installed without permission which caused Teamviewer to have issues with the UDP connection. So even though the computer was accessing the internet alright and the network was stable, the UDP connection was not.

    Rogue switch removed, Teamviewer is working great again.

    Hope this helps someone.

  • Esther
    Esther Posts: 3,614 Community Manager 🌍

    Thanks for your feedback @LuSM

    I am happy to hear the issue is resolved and that TeamViewer is working again for you!

    Have a wonderful weekend,

    Esther

    Community Manager
Sign In or Register to comment.