teamviewer.com link icon
or
Ask The Community

Connect to older version of Mac

I am trying to connect to an older Mac who is not able to update the Mac OS beyond 10.10. When we install TeamViewer it only installs an older version from the website. When we check what version (about TeamViewer) it doesn't say, but just gives a year of 2016. There is no way to update the Mac software and I don't see how to connect from here.

Is there a way I can load an older version of TeamViewer that would allow me to connect to this computer please?