teamviewer.com link icon
or
Ask The Community

teamviewer GUI never comes up on RHEL8

ElCoyote_
ElCoyote_ Posts: 2 ✭✭
edited February 4 in Linux only

Hi,

I previously used teamviewer12 and 13 on RHEL7 as a client to reach other viewers.

I recently tried to use it on RHEL8 (8.5) and no window is coming up in my Windowing environment.

Here's what I see:

$ rpm -qa teamv\*

teamviewer-15.26.4-0.x86_64

Launching the GUI:


$ teamviewer 


Init...

CheckCPU: SSE2 support: yes

Checking setup...

Launching TeamViewer ...

Starting network process (no daemon)

Network process already started (or error)

Launching TeamViewer GUI ...

$ echo $?

127


I used the same process (install the rpm, launch the viewer) on Fedora34 and there it worked (I accepted the EULA and TV came up) but on RHEL8 TV never presents a GUI.

In the TeamViewer Log, I see this:

[removed per Community Guidelines]

Any ideas?

Comments

  • ElCoyote_
    ElCoyote_ Posts: 2 ✭✭

    Got it working by installer libminizip.so.1

    # rpm -qa minizip1.2\*

    minizip1.2-1.2.11-24.el8.x86_64

    IMHO the teamviewer rpm should require libminizip.so.1 to help with dependencies.

  • rolandg
    rolandg Posts: 65 ✭✭

    interesting: the teamviewer-suse rpm has modeled that requirement:

    $ rpm -q --requires teamviewer-suse | grep mini

    libminizip.so.1()(64bit)