teamviewer.com link icon
or
Ask The Community

How to get assignment working with mass deployment?

We are using a trial of TeamViewer corporate license and have been unsuccessful in getting TeamViewer to assign to our account with Easy Access with a script. I have looked at the KB articles online and nothing so far has worked.

This is the script.

msiexec.exe /i TeamViewer_Host.msi /qn CUSTOMCONFIGID=IDGOESHERE APITOKEN=APITOKENGOESHERE ASSIGNMENTOPTIONS="--alias %COMPUTERNAME% --grant-easy-access"

Also tried this.

msiexec.exe /i "C:\Temp\TeamViewer_Host.msi" /qn CUSTOMCONFIGID=IDGOESHERE

ping -n 31 127.0.0.1>nul

"C:\Program Files (x86)\TeamViewer\TeamViewer.exe" assign --api-token=APITOKENGOESHERE --grant-easy-access

No luck. I've spent a good day or two trying to get this working. Am I missing something here?

Tagged:

Answers

  • JeanK
    JeanK Posts: 6,210 Community Manager 🌍

    Hello @StRosesIT,

    I can confirm that the script you are using is correct. ✅

    I recommend trying with an other module (and therefore a new CUSTOMCINFIG and a new APITOKEN.

    Sometimes it resolves the issue...

    Let me know if this has helped!

    All the best,

    JeanK

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • StRosesIT
    StRosesIT Posts: 2 Newbie

    Hi JeanK,

    Thanks for the advise, sadly I tried this a few times and it still doesn't work.

  • RobertoBianchi
    RobertoBianchi Posts: 1 Newbie

    Hi, we have the exact same problem with a corporate demo license.

    On a PC where the script was not working, I tried to assign it manually.

    From that moment, if I uninstall Teamviewer from this PC and reinstall it using the initial script it works and assigns it automatically.


    Clearly I can't do manual assignment for all the PCs I need. So I would like to understand how to proceed to make the assignment from the first launch of the script.


    Do you have any advice?

  • JeanK
    JeanK Posts: 6,210 Community Manager 🌍

    @RobertoBianchi

    Have you tried to use a newly created module?

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer