TeamViewer Support on Wayland - Experimental State

Options
2

Comments

  • kode54
    kode54 Posts: 17 ✭✭
    Options

    Sorry, I didn't notice that log snippets weren't allowed on the forums, and support issue tracker is only available for paying customers. So I guess the forums are just for feedback anecdotes and not actually fixing anything.

    I did discover that it works for Gnome Wayland, I had to install xdg-desktop-portal-gnome, which somehow wasn't installed when I installed the entire gnome desktop package group.

  • PA_trucker
    PA_trucker Posts: 1
    edited May 2023
    Options

    **bleep**. Are you serious?! You have to "allow screen sharing" .. for software that "allows remote control"?

    THAT UTTERLY DESTROYS REMOTE CONTROL and I can now no longer access the device without running through the building to .. access the device. Since that's THE ONLY THING THIS SOFTWARE WAS SUPPOSED TO DO.. and I'm a new Linux user.. can anyone tell me how to de-grade out of the Wayland **bleep** version of TeamViewer or point me at a remote control program .. that actually allows remote control?!!! arrrrgh

  • SHU93129
    SHU93129 Posts: 2 ✭✭
    Options

    As many here have already pointed out - the ability to log in to an unattended workstation is very important, and the current TeamViewer on Wayland does not support this. Would be great if this was somehow implemented.

  • BlastSupport
    Options

    it seems like keyboard shortcuts are not working for me. When i use fedora on wayland, my keyboard shortcuts are not send to the remotely controlled windows machines. The mouse and normal keyboard input work fine, however. Does anyone have a fix for this?

  • HRYKSBT
    HRYKSBT Posts: 17 ✭✭
    Options

    Dear Teamviewer support team,

    When I try to log in with Ubuntu22, I get an error that the server is not connected and will not log in.

    Even the other PC that was able to log in, on the desktop, access is not possible unless sharing operation on the PC being accessed, making the remote useless.

    This only sharing issue happens on desktops, not on laptops.

    As long as the policy is to support Ubuntu, please make sure that it also works correctly with Wayland, which is used by the latest version of Ubuntu.


    Thank you,

  • GlenHuff
    GlenHuff Posts: 1
    Options

    Without unattended device support, I have no use for Teamviewer. I need to access my devices without someone present.

    I attempted to disable Wayland on Ubuntu with "sudo nano /etc/gdm3/custom.conf" in command line and uncomment #WaylandEnable=false. This didn't help. The device doesn't show online and I can't connect to it. So this Wayland update has made the Ubuntu device only available if someone is present to click "Share".

  • vbravov
    vbravov Posts: 1
    Options

    Remote communication priory defined that the person can not reach other computer. Wayladnd completely ruins this definition..

    If you want to use it in restricted meeting or in jail than make the separate function. NOT AS a DEFAULT.

  • gwdteamviewernom
    gwdteamviewernom Posts: 9 ✭✭
    Options

    My Client to connect Fedora (KDE Wayland) could not success for Teamviewer 15.37.3

    In TeamViewer15_Logfile.log show:

    ========================================================

    2023/01/05 18:50:17.469 3925 140320228787648 D  Logger started.

    2023/01/05 18:50:17.469 3925 140320228787648 D  Found 0 stack dump files ...

    2023/01/05 18:50:17.469 3925 140320228787648 D  Found 0 core dump files ...

    2023/01/05 18:50:17.470 3925 140320228787648 D  systemd: logind service available

    2023/01/05 18:50:17.471 3925 140320228787648 D  systemd: New seat seat0 [path=/org/freedesktop/login1/seat/seat0, activeSession='2', canGraphical=1, canTTY=1, canMultiSession=0]

    2023/01/05 18:50:17.471 3925 140320228787648 D  LogindSessionInfo: New session LogindSessionInfo [id=2 user=gwd state=user active=1 reliable=1 infoId=450215437] [path=/org/freedesktop/login1/session/_32 TTY=tty1 seat=seat0 display= vtnr=1 owner=[SysUser: gwd [uid=1000, gid=1000 home=/home/gwd gecos=gwd shell=/bin/bash]] idle=0(0) active=1 type=wayland class=user state=active timestamp=1672915633818854 service=sddm defaultCG= leader=1446 audit=2 remote=0 rHost= rUser= killProc=0]

    2023/01/05 18:50:17.475 3925 140320228787648 D  SysSessionInfoManager: observing sessions from logind is marked as reliable

    2023/01/05 18:50:17.476 3925 140320228787648 D  SysSessionInfoManager: Session Information provided by VT [priority: 2]

    2023/01/05 18:50:17.476 3925 140320228787648 D! FrameBuffer: Cannot access /dev/fb0, frame buffer support unavailable

    2023/01/05 18:50:17.476 3925 140320228787648 D  SysSessionInfoManager::SessionAdded: adding session WaylandSession: [SysSession 450215437 [type=87 vt=1 tty= pseudotty=0 info=1 id=2 user=gwd state=user active=1 reliable=1]]

    2023/01/05 18:50:17.476 3925 140320228787648 D!! SysSessionInfoManager::GetOwnProcessSession: No session found!, Errorcode=11

    2023/01/05 18:50:19.482 3925 140320228787648 D  Cannot acquire lock for "/run/user/1000/tv_desktop.lock", reason: locked by other process (3070)

    2023/01/05 18:50:24.487 3925 140320228787648 D  Shutting down DBus IOHandler

    ========================================================

    startup.log show:

    ========================================================

    Init...

    TeamViewer:       15.37.3 - RPM

    Profile:          /home/gwd (gwd)

    Desktop:          DS: 'plasma'   XDG: 'KDE'

    XServer TTY:      none


    ok (info)


    CheckCPU: SSE2 support: yes

    ok (profile)

    ========================================================

    It would 100% occur in Fedora Labs (Scientific).

  • gwdteamviewernom
    gwdteamviewernom Posts: 9 ✭✭
    Options
  • shmizan
    shmizan Posts: 1
    edited May 2023
    Options

    I'm having the same thing. did you solve the issue?

    @JeanK I think there's a bug in TeamViewer, because on Ubuntu, any software that wants to use the key shortcuts, asks for a permission to "Inhibit Shortcuts", and then it can send shortcuts:


    but for TeamViewer that has never happened.

    I can't sent any key combinations to the remote Windows machine.

  • oldhamtech
    oldhamtech Posts: 1
    Options

    2FA using the teamviewer client on mobile to give permission to a desktop connection is not currently supported in Wayland, though it is in X.org. We need this feature in Wayland.

  • orkol
    orkol Posts: 1
    Options

    using fresh install of fedora 38. logitech mx master 3 cursor position is not clicking and pointing in the right place. in other apps it's ok. it's only in teamviewer. using akmod nvidia drivers (from rpmfusion). teamviewer_15.41.7

  • ContalovTV
    ContalovTV Posts: 1
    edited May 2023
    Options

    Mine does support incoming connections, but it never gets up the allow/deny prompt of wayland asking for screen sharing permission, resulting in my phone getting stuck on "connecting" prompt and not getting into remote control screen, however the sounds of the desktop do get shared and are audible on my phone (Ubuntu upper icons also indicate the mic is getting shared)... [removed per Community Guidelines]

  • rafaellinuxuser
    rafaellinuxuser Posts: 2 ✭✭
    Options

    I am starting to use Wayland. I have Plasma on OpenSUSE Tumbleweed and the latest version of Teamviewer installed. Teamviewer shows me the message that I am using Wayland. So far, so good. When I try to connect, after entering the password shown on TV, the floating TV window appears with the chat and the device I'm trying to connect from (a mobile phone). However, finally that floating window closes and the main TV window reappears. What can I do to provide you with information about this?

    Thanks


    Operating System: openSUSE Tumbleweed 20230422

    KDE Plasma Version: 5.27.4

    KDE Frameworks Version: 5.105.0

    Qt Version: 5.15.8

    Kernel Version: 6.2.12-1-default (64-bit)

    Graphics Platform: Wayland

    Graphics Processor: NVIDIA GeForce RTX 2060/PCIe/SSE2

  • rafaellinuxuser
    rafaellinuxuser Posts: 2 ✭✭
    Options

    I must add that SESSION IS ALIVE, but my remote client (smartphone) only shows "Wait to stablish connection" and in remote PC appears my smartphone name and IP, like it were connected.

  • moscardo
    moscardo Posts: 1
    Options

    Hi guys,

    I need to login to the my Linux Ubuntu 22.04.3 LTS (using gdm3) via Wayland because of a series di graphics problems which are present in Xorg but solved in Wayland.

    As said before I have a problem in trying to connect to my machine: someone always have to grant permission on the incoming connection:

    Is there a way, as September 2023, to solve this issue without having to use Xorg?

    What is the current state of the art on this issue? Is there any other working workaround?

    Thank you so much for your support

  • bayazidbh
    bayazidbh Posts: 1
    Options

    There have been a lot of Portal works recently that would help, primarily remote-desktop-restore-token, inputcapture, and clipboard portals. Hopefully it would mean that TeamViewer could be offered as a Snap and Flatpak soon (or at least just not require install on root - quite annoying on immutable OS where I prefer to use Flatpak, Distrobox, and Nix)

  • Wonder_Wonder
    Wonder_Wonder Posts: 4 ✭✭
    edited September 2023
    Options

    I have recently installed (fresh install) Debian 12 Stable installation with KDE.

    By default it comes with Wayland.

    I install Teamviewer in its latest version, it tells me that Wayaland is detected but ok (like the first image in this thread).

    Ok, when I want to connect to this computer (from my mobile to test) I get the following KDE screen and it doesn't allow me to connect:

    Translated it indicates:

    KDE Portal Integration

    Failed to start screen recording

    Failed to create PipeWire context.


    Remote control session started

    You have requested access to:

    - Screens

    - Input devices


    And there it stays, therefore, I can't get past it.


    Any solution for Wayland?


    Debian 12 Stable, KDE 5.27.5, Kernel 6.1.0-12.


    Thank you.

  • JonasE_TV
    JonasE_TV Posts: 6 Staff member 🤠
    Options


    Hello Wonder_Wonder,

    What kind of system does your Debian run on? I was able to reproduce this problem with Debian 12 running in a VirtualBox machine when 3D acceleration of the machine is disabled (which it was by default). Syslog also got spammed with messages

    kwin_wayland_wrapper[892]: kwin_wayland_drm: Failed to record frame: Error creating EGLImageKHR - "EGL_BAD_ALLOC"

    After I enabled 3D acceleration (with VMSVGA controller), I could successfully connect.

    And btw, Krfb showed the same issue, so it seems this problem is not actually specific to TeamViewer.

    Kind regards

    Jonas

  • Wonder_Wonder
    Wonder_Wonder Posts: 4 ✭✭
    Options

    I have this problem on a desktop computer, not on virtualbox, it is my own computer.

    The graphics card I have is amd RX 480 8GB.

    Regarding: "And btw, Krfb showed the same issue, so it seems this problem is not actually specific to TeamViewer."

    I don't know or have no knowledge about Krfb, I have searched for it in this thread, and I haven't found anything about it.

    If I change my Debian12 session from Wayland to Xorg then it works, I think it's Teamviewer with Wayland on Debian12 KDE

  • JonasE_TV
    JonasE_TV Posts: 6 Staff member 🤠
    Options

    There is also another test you can do to see whether screen capturing works in general. Just open this web page with Firefox and select "Screen capture". You should see an infinite tunnel of your screen...

  • Wonder_Wonder
    Wonder_Wonder Posts: 4 ✭✭
    Options

    Right, that's right...

    Debian 12 KDE stable, by default Wayland but NOT Pipewire.

    I'm discussing this problem on the db forum, and something as simple as Pipewire, I didn't think about it not being installed...

    I have installed it, indeed, now I don't have that error...now it connects and displays but not well.


    Your link for Firefox is exactly how Teamviewer worked for me in X11, I have two screens, I saw one, I could go from one to the other.


    Well, now, after installing Pipewire and configuring it following the debian wiki, Teamviewer connects me but... it shows me the 2 screens as if it were only 1, and the mouse is not displayed (it is difficult to explain in writing).

    In your Firefox link that didn't happen, first it asked me what screen to show, I selected 1, and then, that's right, infinite tunnel but I saw the mouse move.

    As I indicated, now, Teamviewer connects but my two screens appear as a single screen and the mouse, despite moving, I don't see it so I don't know where I am or anything...

  • JonasE_TV
    JonasE_TV Posts: 6 Staff member 🤠
    Options

    Hello moscardo,

    thansk for your feedback. As bayazidbh already mentioned, recently there have been many changes and improvements of the interfaces which TeamViewer uses to request screen sharing on Wayland systems. This should now also make it possible to add support for unattended access, so that users do not have to approve every time.

    However, I do not expect that to be implemented/backported for Ubuntu 22.04 anymore. So there, using Xorg will most probably be the only option.

  • targettor
    targettor Posts: 2 ✭✭
    Options

    Found on problem on Ubuntu 23.10 (Wayland / Gnome):

    While a Teamviewer client is connected to the Teamviewer server on Wayland, closing Teamviewer on Wayland results in a crash of the Teamviewer application.

  • JonasE_TV
    JonasE_TV Posts: 6 Staff member 🤠
    Options

    Hello targettor,

    thanks a lot for the feedback. We'll have a look into that.

  • dagufri
    dagufri Posts: 1
    Options

    Hello everyone,

    I'd also like to get TeamViewer running on Wayland.


    Connecting from a Mac, I get a "Starting remote session" message, but that's where it stops.


    Connecting from a Win machine, I only get "Remote control is currently deactivated on the device".


    I can choose to share the screen, keyboard, and mouse on the laptop, but it makes no difference.

    There's an orange icon in the top left corner "Screen is Being Sharing".

    I don't see any error messages.


    I've got the following on the laptop that I want to connect to:

    • Debian 11
    • Gnome Wayland
    • Pipewire package version 0.3.19-4
    • TeamViewer 15.46.7 QS


    Any tip on what I can troubleshoot?

  • lukuc
    lukuc Posts: 1 Newbie
    Options

    connection not working at all
    logged to account, computer is visible, but still in connecting state. minutes, hours…

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.