teamviewer.com link icon
or
Ask The Community

File transfer not working with Raspberry Pi 64 bit host

ronperek
ronperek Posts: 2 ✭✭

Hello,

I'm connecting from a Windows PC to a TeamViewer host running on a 64bit Raspberry Pi. I can't browse the files on the host or transfer any files. For unknown reason, one time the browsing on the host worked for few seconds, then it stopped. The title bar shows "Remote computer (processing your request...)". When I try to start the file transfer again, I get information: "The file transfer could not be started because it was denied on the remote computer"

Browsing files, creating directories etc. on the client computer works.

It doesn't matter if I'm running headless or with screen. Same result.

In advanced options / Access Control is set to "Full Access"

Host info:

Linux Raspberry Pi 5.15.56-v8+ #1575 SMP PREEMPT Fri Jul 22 20:31:26 BST 2022 aarch64 GNU/Linux

TeamViewer                          15.32.3 (DEB)

When running TV 15.32.3 from repository, the above happens. When I installed version 15.33.7 from TeamViewer website, an attempt to browse files sometime results in a TeamViewer crash on the host.

As far as I remember, while I was still using the 32bit system on Raspberry Pi, the file transfer worked fine.


Answers

  • ronperek
    ronperek Posts: 2 ✭✭

    From the lack of feedback, it looks like no one is getting the same issue. Fortunately, I found the root of the problem and a solution.

    I found a file with some wicked name in the /home/pi directory. It looks like a result of some app crash. I don't know how it got there. As soon as I removed it, the TeamViewer file transfer started to work without a problem. I attach a picture with the name of the file as seen by the Linux system.

    That solves the problem, however, the bug in TeamViewer exists that causes the TeamViewer file transfer to crash if a file with a strange name exists in the home directory. Devs, please fix this.