Trouble installing 64 bit Team Viewer after uninstalling 32 bit Team Viewer

helper_me2022
helper_me2022 Posts: 2 ✭✭
edited November 2022 in General questions

It started with the shortcuts on my desktop / task bar not working for Team Viewer earlier today, so I thought I'd check for the program file - and uninstall and reinstall it. Did that, using control panel uninstall programs, and then I restarted the computer and tried to install the 64 bit most recent release of Team Viewer. (I had downloaded it prior to uninstalling the 32 bit program and restarting). FYI I'm installing 64 Bit simply because I found out my system is 64 Bit and didn't know I had 32 Bit installed. Figured that was part of the problem I was having with Team Viewer.

Now when I try to install it (64 bit Team Viewer), I get an error saying there's a 32 bit program already installed, uninstall it and try to install the 64 bit program once that's done.

Not sure what I'm getting wrong - I've verified through both the 'search' to find an app on the computer from task bar (think its the cortana function), and through the control panel and there's no Team Viewer file or link there. There's also no Team Viewer in the File Explorer where programs are listed.

HELP! I need this program to connect to my elderly Mom's computer in another city and help her with her computer. As a side note, the Team Viewer I had installed said it was the most recent version and all settings were the same as they always have been - but it was NOT working to connect to her computer for the last 3 weeks - and she has changed nothing on her end either. Strangely enough, I could connect to my other computers (all on the same network at my home) via Team Viewer as recently as this morning using the shortcut on my task bar, so I'm not sure what the situation is on this.

EDIT: I just decided to try downloading and installing the 32 bit team viewer on a whim and it is now working on my computer - at least I can connect with it to my local computers (elsewhere in the home, not outside the home) - so STILL having trouble connecting to my elderly Mom's home computer - and my computer is still a Windows 10 Pro - 64bit op system - so not sure why the 32 bit is working (or rather let me install it). HELP my Mom needs me to help her on her computer and I'm 2 hours away and can't get there.

Thanks!

Helper_me2022

Answers

  • helper_me2022
    helper_me2022 Posts: 2 ✭✭


  • smillerIT
    smillerIT Posts: 1

    I have the same problem on a 64 bit desktop, but Teamviewer does not appear in the start menu, in the Apps under settings or in the programs in Control Panel. I have tried to reinstall the 32 bit version but when I am prompted for an Admin account (even though mine is an admin account) and try several Administrative accounts, the installation fails with a "Error: Rollback framework could not be initialised. Installation aborted!"

    The only success I have had is to lauch TeamViewer as Run Only (one time use), and it appears to have saved all of my settings, including Easy Access and the password for Options, but it is not linked to my account, and I cannot add this as it is not recognising me or any of the Admin accounts as Admins. I also cannot add my account, set startup with Windows or Wake from Lan though the PC still shows in my account under the same TeamViewer ID, etc.

    Is there a way to completely removed the 32-bit version so I can install 64 bit and set this up properly?

  • SPEEDFREQ
    SPEEDFREQ Posts: 1 Newbie

    If you don't have Teamviewer 32 bit listed in programs but are still getting the error to remove it before installing 64 bit, REGEDIT Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\teamviewer and delete the whole teamviewer folder then reboot and restart 64 bit install you should not get error any longer