teamviewer 12 on ubuntu 17.10 unable to allow incoming remote connections. But I am able to remote.

Options
chamilton
chamilton Posts: 1

I just got Teamveiwer 12 installed on ubuntu 17.10 and i am not able receive incoming remote connections. However, I can get remote out with no prob.

Comments

  • ChristianCay
    ChristianCay Posts: 182 [Former Staff]
    Options

    Dear chamilton,

    Thank you for your post.

    To make sure we are able to understand your issue, do you have a TeamViewer ID on this device?

    Are you able to make outgoing connections?

    Do you have Wayland Enabled?

    Let us know so we are able to find out a solution for you.

     

    Best regards,

    Christian

    Did my reply answer your question? Accept it as a solution to help others, Thanks.
  • FranklinNoyes
    FranklinNoyes Posts: 2 ✭✭
    Options

    I just upgraded to Ubuntu 17.10 which now uses GNOME instead of Unity as the default desktop environment. When I connect to my Ubuntu machine (from any other device regardless of OS) I just see a black screen in the remote window. I'm using Teamviewer 12, and I've already tried purging Teamviewer and reinstalling it.

    I should mention that if I log out of GNOME and into Unity it works just like before, so the problem must be related to the new desktop envirnment.

  • goldenweek
    goldenweek Posts: 1
    Options
    I had the same issue with @FranklinNoyes after I upgraded to 17.10, looks like it is a common issue, is TeamViewer team going to help us with a patch for it?
  • Soren1271
    Soren1271 Posts: 1
    Options

    I did two fresh install of Ubuntu 17.10 and installed Teamviewer but when I try to connect to my Ubuntu machines from Windows or Ubuntu OS, I receive the error seen in image below. I'm using Teamviewer 12.

    This is the error I recieve:

    teamviewer ubuntu error.PNG

    Regarding Your Questions:

    To make sure we are able to understand your issue, do you have a TeamViewer ID on this device? 

    Answer: I recall seeing one when I was connecting to other nodes from the node.

    Are you able to make outgoing connections?

    Answer:  Yes I am able to make outgoing connectiones.

    Do you have Wayland Enabled?

    Answer: That is now the default display server.

  • mr_endres
    mr_endres Posts: 1
    Options

    I have the same problem with a fresh 17.10 install. However choosing Xorg session from login screen solves the problem (e.g. https://itsfoss.com/switch-xorg-wayland/)

    Nevertheless a solution for wayland would be very nice.

  • Trudide12
    Trudide12 Posts: 5 ✭✭
    Options

     Hello, I  have the same problem. Black screen after logon with latest teamviewer 12 on Ubuntu 17.10. I am on Xorg, not on wayland. I reinstalled the client, same. 

  • Trudide12
    Trudide12 Posts: 5 ✭✭
    Options

    I also tested switching back to Unity, no way the session stays black. 

  • dmitrobv
    dmitrobv Posts: 2 ✭✭
    Options

    the same issue :(

  • lucasaba
    lucasaba Posts: 2 ✭✭
    Options

    Same here! :smileysad:

  • maggiv8
    maggiv8 Posts: 4 ✭✭
    Options

    S(h)ame here...

  • dmitrobv
    dmitrobv Posts: 2 ✭✭
    Options

    Solution found.

    Just set Ubuntu on Xorg before login, and it works!

  • Trudide12
    Trudide12 Posts: 5 ✭✭
    Options
    It's not a solution, it's a **bleep** workaround. Solution will be to support Wayland where all Linux communities are going.
  • maggiv8
    maggiv8 Posts: 4 ✭✭
    Options
    This is not a solution, but a workaround only.
  • bkjaya
    bkjaya Posts: 4 ✭✭
    Options

    How to change the desktopHow to change the desktop

    To view the remote desktop I have successfully adopted the following simple procedure.

    The default desktop of Ubuntu 17.10 ,has to be changed from Ubuntu to Ubuntu on Xorg

    Start computer and make changes (select Ubuntu on Xorg) in the Ubuntu login screen as above.

    Then enter the password of the computer and start

    Then  the problem will be  solved

  • lucasaba
    lucasaba Posts: 2 ✭✭
    Options

    As @Trudide12 and @maggiv8 posted, this is a workaround, not a solution!

  • vitrion
    vitrion Posts: 3 ✭✭
    Options

    This is the solution I was looking for in Fedora 25. Now I understand it all.

    Thank you very much!!!