What is the best way to actually get support?

Options
AustinGraham
AustinGraham Posts: 3 ✭✭
edited May 2023 in General questions

I have opened multiple tickets and they just don't get back to you promptly. I heard calling was faster.

I tried calling in and I waited in the Queue. I finally hit first in line, but after 5 minutes they hung up on me. If I need to be bumped then bump me, don't make me a call again. This is outrageous. I pay thousands a year for Corporate Teamviewer and I get no help.

Any tips and tricks to get their attention?

Answers

  • Ying_Q
    Ying_Q Posts: 2,633 Moderator
    Options

    Hi @AustinGraham,

    Thank you for visiting the TeamViewer Community!

    As the TeamViewer Support Team is now facing an extremely high volume queue from our customers, we appreciate your patience in getting the response from the TeamViewer Support Team.

    May I ask what was the key issue or question you would like to raise with TeamViewer? Is there anything we may help with from the TeamViewer knowledge articles or the forums?

    Hope to hear from you and be able to help you out!

    Best,

    Ying_Q

    Community Moderator/中文社区管理员
  • AustinGraham
    AustinGraham Posts: 3 ✭✭
    Options

    @Ying_Q Thanks for the response!

    I have checked the forums and articles, but I very well may have missed something.

    My problem is two-fold. My connection via teamviewer remote access only works once in a day after numerous reboots on a particular machine. I have to use the Prompt for confirmation choice though since I have no passwords

    Secondly my Easy Access has never worked despite reading the articles about assigning a device and removing all passwords.

    I know the device is active and on the network because I can always access it with a low-featured free alternative remote access tool.

  • AustinGraham
    AustinGraham Posts: 3 ✭✭
    Options

    I called today and was helped by Patrick. He was great and helped me solve both my issues at once.

    I had everything setup perfectly, but my Teamviewer was out of date. I couldn't connect to my machine through the Computer "Groups" which is being deprecated. I needed to connect through the new "Device Groups" which isn't shown if you're using an older version of the teamviewer client. I needed an admin to update it for me, but now its good to go.


    Thanks Patrick and Thanks @Ying_Q

  • Ying_Q
    Ying_Q Posts: 2,633 Moderator
    Options

    Hi @AustinGraham,

    I am sorry for the late response from my side, but Thank you for sharing the positive update! I am so happy to hear that the support agent Patrick helped you on solving the issues.

    Feel free to reach out to us in the TeamViewer Community again if you would like to join any discussion and also check out the knowledge-based articles.

    Wish you a great day!

    Best,

    Ying_Q

    Community Moderator/中文社区管理员