link icon
Ask The Community

Says 'ready to connect', but won't connect.

I've been using TV for over a year to connect to a remote PC and it has been working fine. Today, I rebooted the remote PC and as usual TV asked if I wanted to be reminded when the PC became available again. Once it did, and reported that the connection was available, I selected 'Connect', but the login/password screen failed to appear. I've tried several times and once got a message that I should wait awhile.

How long should I have to wait, and is there any other way to get a connection? I'm concerned that I tried too early while the PC was still finishing its restart and somehow hung up TV on the remote PC.


  • RavenRaven Posts: 23

    Hi billvv,

    In my experience, TeamViewer should only send you an invitation to re-connect once it has restarted on the remote terminal.  It typically occurs when you are doing a remote update or, as you have stated, a reboot of the remote terminal.

    Since your scenario relates to a reboot, it is possible that there are other factors at play, such as a system service not having started properly on system boot.  If the remote PC is part of a network, you might be able to access a list of its services from the server or a.n.other workstation on the same site, to restart the TeamViewer service.

    For example :-

    On a networked Windows box, press ctrl + r to call up the run dialogue and type compmgmt.msc and hit enter.  This will call up the Computer Management screen.  If you then right-click on "Computer Management (Local)" (the top option in the left-hand pane), and select the "Connect to another computer ..." option, you should be able to connect to another computer on your network (being the one that isn't responding to your remote request).

    Once you are connected to the offending computer, expand the "Services and Applications" dropdown, and click on "Services" to see a list of all the services running on the remote PC.  You should be able to see from here whether the TeamViewer service is running remotely or not.

    In your specific scenario I would anticipate that it *is*, but that it might need restarting, which you can do by right-clicking on the service (mine is "TeamViewer 12", for instance), and selecting "Restart".

    Obviously this advice is predicated on a number of hypotheticals such as your level of access to remote terminals on-site; how your network is operating (assuming you are operating a network); and so on, but even if this advice does *not* apply in this specific scenario, it's helpful for your future reference I guess =]

    Another idea I had is that sometimes I have found this hanging effect can happen when the remote computer has a dialogue box (e.g. a security warning - anything that conflicts with the local PC's UAC (User Account Control) settings, or similar).  On occasion you have to have the remote-user clear this dialogue in order for TeamViewer to be able to negotiate a healthy connection.

    Hope some of that helps !

    - Raven
Sign In or Register to comment.