Teamviewer Connectivity Issue in Fedora 26 as Guest OS


I have an Window 10 Pro as the OS for my laptop.  I created a VM using VirtualBox and the Guest OS is Fedora 26 Workstation.  I installed Teamview 12 on this Guest OS Fedora 26 Workstation.  It worked fine.  But after a reboot of the VM, it fails to connect while after reboot I am able to access the internet from the Guest OS. Attached two screen shots of the same for reference.   Please note there are no proxy servers set.  

Thank you in advance for your help in this regard.


Immediately after installationAfter reboot of VM 2After reboot of VM 2After reboot of the VM 1



  • The following are the details obtained when I ran teamview info from the prompt.

    [1m TeamViewer                          [0m 12.0.76279  (RPM) 

    [1m teamviewerd status [0m ● teamviewerd.service - TeamViewer remote control daemon
    Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: disabled)
    Active: active (running) since Thu 2017-09-21 19:08:11 CAT; 4min 55s ago
    Process: 2718 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
    Main PID: 2720 (teamviewerd)
    Tasks: 23 (limit: 4915)
    CGroup: /system.slice/teamviewerd.service
    ├─2720 /opt/teamviewer/tv_bin/teamviewerd -d
    └─2945 /opt/teamviewer/tv_bin/TeamViewer_Desktop --IPCport 5939 --module 1

    Sep 21 19:08:11 localhost.localdomain systemd[1]: Starting TeamViewer remote control daemon...
    Sep 21 19:08:11 localhost.localdomain systemd[1]: teamviewerd.service: PID file /var/run/ not readable (yet?) after start: No such file or directory
    Sep 21 19:08:11 localhost.localdomain systemd[1]: Started TeamViewer remote control daemon.
    Sep 21 19:10:42 localhost.localdomain su[2946]: (to ramana) root on none

    [1m TeamViewer ID: [0m 124738124