teamviewer.com link icon
or
Ask The Community

Screen Blanking

Is there a way to blank the screen on a remote computer (for security reasons)? I use TV on a Linux Ubuntu 12.04 LTS system and a 14.04 LTS system, accessed with my Android tablet using the app.

Best Answer

Answers

  • Dmccr
    Dmccr Posts: 6
    When installing and configuring TV on the remote computer you can select the screen behavior during RC sessions. My use is almost always assisting the user at the remote machine, so I don't recall the specific screens. If you don't find the setting, just ask - I'm sure someone can give you a step - by - step.
    Posted First Teamviewer Community Message!
  • I will look into it and re-install if necessary. Thank you!
  • Dmccr
    Dmccr Posts: 6

    Now that I'm in front of a computer to check for it, the solution is simpler than I remembered.  When you are controlling the remote computer, go to the menu at the top of the screen, "Actions" tab, check the "Show black screen" box.

     

    I'm struggling to add a screen shot to this post... I'll add it when I figure it out.

    Posted First Teamviewer Community Message!
  • Dmccr
    Dmccr Posts: 6

     

    Menu2.JPG

     

    Posted First Teamviewer Community Message!
  • My remote machines are both Linux. I don't have that option available. It's greyed out and disabled. I usually access them with my Android tablet. I don't even have that menu bar on it.
  • That is, when I access one Linux machine with the other one, that option is greyed out. When I access either with my tablet, I don't have that menu.
  • Scotty
    Scotty Posts: 494 Staff

    -EDIT-

     

    Currently, Screen blanking is ony available when connecting to windows. This is due to the way that TeamViewer blanks the remote screen while still displaying on the local side using special display drivers.

     

    However, this can be done from linux, Mac, iOS and Android. The toolbar should look like the screenshots provided above by Dmccr for everthing except Android and iOS.

     

    The trick from Android is that you must select "Tools" (the little spanner) and block remote user input first. Once this is done, select tools again and the option to "Show back screen" will appear. I believe iOS is similar, but I don't have a device to test at the moment.

     

    This is currently in as a "feature request"  for other operating systems and is something that may be expanded in the future to include other operating systems, but isn't available at the moment.

     

    I'm sorry about that dtstanton, I'm a linux lover too. (Kubuntu)

    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • "The trick from Android is that you must select "Tools" (the little spanner) and block remote user input first."

     

    I don't find those options. I don't have a spanner or wrench, only the gear in the lower right corner on my tablet (Nook Samsung Tab4 10.1, TV v. 11.0.5173 CL).


    TV Screen.png

     

    When I click on it, it takes me to this screen:

     

    TV Options.png

     

    I do get the drop down menu when I connect from Linux to Linux, though (both machines using v. 11.0.53191 wine-1.6).

     

    TV Dropdown Menu.png

     

    Am I looking in the wrong place?

     

  • Strange. I updated both of my Linux machines to the latest version and removed and re-installed the app from the Play Store. Now I see the wrench at the bottom of the screen while I'm connected to one of my Linux boxes. Same app version number as I stated above. When I click on the wrench (spanner), I only get one option: Lock computer. When I select it, the remote machine locks down as expected.
     
    I was able to find a "Disable Remote Input..." option throught the Computers list, under the settings icon, Advanced tab. It doesn't seem to make any difference.

     

     

  • Forgot the screen shot, sorry.

     

    Disable Remote Input.png

  • Understood. Part of my problem is I was trying to go about it wrong. Thank you, Scotty!
  • cowst
    cowst Posts: 8

    Is support of this in Linux considered as incoming feature at some point?

  • dtstanton
    dtstanton Posts: 11

    Not that I'm aware of. The TeamViewer people might be working on something, though.

  • Hi i followed your instructions and installed the monitor driver, but what do i do next please?  Pc is running Windows, i am using the app on an ipad.  I cant find any tools on the ipad when connected remotely that will let me blank the screen.  I have a bunch of icons along the bottom of the screen but none of them give me any options to black the screen of the pc at home.

Sign In or Register to comment.