link icon
Ask The Community

No connection to TeamViewer Server - Please check your internet connection

I'm using TeamViewer v12 on windows since a long time and have no problem with it until this morning. 2 stations : one desktop at home and one laptop at my company. I use my laptop at work to connect on my desktop at home.

NOTE : Yesterday I probably messed up with another program : Proxifier. It had probably messed up windows socks but TeamViewer seems not to have any trouble to connect at that moment so it may not be related but I think it worth mentionning.

This morning after a fresh reboot TeamViewer can't connect to master server. (TV v12 on laptop works perfectly fine)

The log file contains some strange lines

2017/09/27 22:06:53.814 13544 13516  0   Logger started.
2017/09/27 22:06:53.856 13544 13516 0!! LocalIPAddresses: getaddrinfo failed with socket error 11001, Errorcode=1008
2017/09/27 22:06:53.856 13544 13516 0! AsioSettings::FindExternalIP: found 0 external IPs instead of 1!
2017/09/27 22:06:53.858 13544 13516 0 UpdateOnlineState newOnlineValue 1
2017/09/27 22:06:53.858 13544 13516 0!! LocalIPAddresses: getaddrinfo failed with socket error 11001, Errorcode=1008
2017/09/27 22:06:57.401 13544 14080 S0!!!CTcpConnectionBase[5]::HandleResolve(): Resolve failed,, Error: system:11001
2017/09/27 22:06:57.401 13544 14992 S0 Activating Router carrier
2017/09/27 22:06:57.416 13544 14992 S0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host:
2017/09/27 22:06:57.416 13544 14992 S0!! Port443Connection::ConnectInternal: failed with HTTP status code = 0
2017/09/27 22:06:57.416 13544 13496 S0!! NetWatchdog: Port 443 proxy search failed! No working setting found.
2017/09/27 22:06:57.416 13544 13496 S0 Activating Router carrier
2017/09/27 22:06:57.432 13544 14992 S0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host:
2017/09/27 22:06:57.432 13544 13496 S0!! NetWatchdog: Port 80 proxy search failed! No working setting found.

as you can see, it seems that TeamViewer can't resolve any address therefor can't connect to master server. Oh, and only TeamViewer seems to have trouble to  Internetaccess. I have no problem with every other programs.

So after some search on Internet I found some hints on what to look and what to do and on this forum I had numerous possible solution. So here are my attempt to fix it :

  • I've tried to stop service and start again => No connection either
  • I've tried a fresh install, and even with a previous version (from July) => No connection
  • I've tried to disable IPv6 to force IPv4 DNS resolve without success
  • I've change my ISP DNS by Google's one - and even with independant French DNS to test it => No connection
  • Because I can in console ping everything, I've tried to put IP of ping3 / master1-2-3-etc/ directly in etc/hosts to force resolving locally => Still no connection
  • I've tried to flush socks with netsh winsock reset in console => still no connection
  • I've tried to patch Windows.NET with some patch recommanded on forums => still no connection

So i'm little out of option here... Do you have any idea of what can I do to fix that ?

Best Answer


  • Happening on V13 for me as well. Any solution?

  • I have the same problem.

    I had exactly the same problem in TV12 under windows 10, and thus I modified the hosts file to make it work.

    This is not working anymore today, even when I updated to TV13.

    However, pinging the domain name under cmd looks fine...

    Other internet connection looks fine, too.

  • In my case, I found out the client had double NAT'ed.

    One router (supplied by ISP) in front of another router (their own). Removing the 2nd router solved the issue.


  • I'm having trouble with TV v8 unable to get a connection after the Fall Update. It knows there's an update available and clicking the link works fine.

    It was working fine before, but something in Windows has changed to prevent it.

    I've since been in Windows and done a full Reset to reset the operating system back to default state and that didn't fix it. I've also reinstalled Windows from a memory stick & that didn't fix it. I've reformatted the hard drive & reloaded Windows and it's now working fine. I have several PCs in the same state & I really don't want to have to reformat them all just to get the TV Host to register itself! 

    I have a license for commercial use of TV8  so I don't want to upgrade to TV13 as I'll have to pay lots of money & it may not fix it!

  • Hi,

    Came across this post as I had the exact same issue.  I was using Kaspersky Total Security 2017 (patch k) and  Fall Creators Update (Windows Version 1709).

    I've just upgraded Kaspersky to 2018 ( patch f) and the problem no longer exists.

    The upgrade was quick and painless and after reboot my team viewer application (13.1.1548) in my tray connected successfully.

    Hope this helps someone.  So if you have an active Kaspersky subscription then you should be able to upgrade and hopefully teamviewer should start functioning again.

    Happy to respond to any specific questions.

    All the best.

    Duncan aka Mortal-Wombat

  • Willem48Willem48 Posts: 1


    I am on a camping and get these announcement , but when i AM AT HOME THERE IS NO PROBLEM. iNTERNnet works fine. Who can help me.

  • I spent a few hours uninstalling and reinstalling Teamviewer and uninstalling and reinstalling virus protection and firewall and TV still would not connect. This has been a problem for me for at least a month. 

    Finally found a simple fix and it does relate to the internet connection and works for the latest TV version. The problem is a conflict with network adapter IPv4 and IPv6. Disable IPv6 and TV will connect instantly.

    In Windows 10: All settings>Network and Sharing Center>Change Adapter Settings>WIfi Properties>Untick IPv6

  • radek_radek_ Posts: 1

    Just bumped into this thread today having the same issue.

    In my case upgrading VGA driver solved the problem immedaitely.

    I vaguely remember that few months ago TV13 was playing up, then started working again after few days with no appparent reason - I bet the fix was the same back then.


    I too am having the same problem of not being connected to the Internet.  My server is up and running, and I have a connection - just not with TeamViewer.

    Also, I can not enter any info because the "Activate" button(s) are not highlighted.  TeamViewer keeps asking me for my proxy settings....... (?)

    Please help.  What am I suppose to do?

  • JMakJMak Posts: 2

    I see this No connection to TeamViewer server when laptop go to sleep and waking up from sleep.

    So I know the issue is no internet connection while laptop is waking up, is there a way to deploy the TeamViewer Host in mass and supporess this error?

    Best to stay silent in the background and not pop-up at the user when computer wakup from sleep. (Win10 2004)

Sign In or Register to comment.