link icon
Ask The Community

Battlefield game flickers when TV is running

Some of the  games I run, especially Battlefield games, flicker when TeamViewer is running in the background.  It also won't allow the game to go to full screen.  Is there a fix for this?


  • A few other games and 3D applications have problems too in full-screen. 

  • A potential solution is this from the Battlefield forums;

    Like another has said, there is only one feature of TV that conflicts with BF3. That feature is called "QuickConnect", and in some applications it causes an extra button to appear at the top of your window next to the minimize button. I'm not sure what QuickConnect does, but I think it allows you to share application windows with other clients. 

    Anyways, QuickConnect can be disabled altogether, or you can simply add an exception for BF3.

    To disable QuickConnect:

    1. Open up TeamViewer
    2. Click "Extras", then "Options".
    3. Click "Advanced" at the bottom of the left menu pane, then "Show advanced options".
    4. Next, click "Configure" next to "QuickConnect button"
    5. Un-check the box at the top that says "Show QuickConnect button". This will disable QuickConnect altogether.

    To add an exception:

    Follow above steps 1-4

    Instead of un-checking the "Show QuickConnect button" box, simply type "bf3.exe" into the text area then click "Add", and "Ok". Press "Ok" once more to exit the options menu and you should be good to go. QuickConnect will still be enabled, but not for BF3. Hope this helps someone out there.
Sign In or Register to comment.