Control-Click TeamViewer Mac Not Working When Controlling PC?

Options
msg
msg Posts: 27 ✭✭

Hey guys, I'm working with some Windows PCs from my Macbook today, and while working in an Excel document on the remote PC client, I'm noticing that I'm unable to Ctrl-Click to select multiple cells in Excel, for example.  It's as if the Control (CTRL) key is being ignored.  It simply changes the selection focus to the next cell I click.

I've verified that this works properly from a remote session using the PC version of TeamViewer, so nothing going on on the remote PC side.

I've tried this with two different remote PC clients.
Tried various key combinations (Command, Opt, etc.)
Checked my keyboard preferences on the Mac side
Tried forwarding key combinations.

Ctrl+A works to Select All
Shift+Click works to Select a Range
Just can't seem to get Ctrl+Click to work to select multiple non-adjacent cells.

Nothing's working so far; Can't seem to figure this one out.
I presume this should work correctly, yes?
Any ideas?

Tagged:

Comments

  • msg
    msg Posts: 27 ✭✭
    Options

    Kind of figured this out, but leaving it up here in case anyone else happens across a similar problem.

    This issue seems to be with some setting in the user profile on the Macbook side.  Tests fine with a second MBP,  which was running a slightly earlier version of TeamViewer 12.  I updated that to confirm, and the second MBP still worked just fine in CTRL+Clicking in remote Windows PCs.

    I created a second test profile on the primary Macbook.  TeamViewer worked properly to CTRL+Click objects in the remote Windows PC, leading me to the issue being something in the user profile.  Now to figure out what that is...

    I've already reviewed the keyboard settings for shortcuts and such, and all seems to match between the two machines, so I'm thinking maybe there's something going on with an application, causing this conflict.

  • TimH
    TimH Posts: 1
    Options

    I just found a fix for this (was having the same problem): on a Mac trackpad, clicking with two fingers instead of just one gives you a right click. So while ctrl-click seems to not work anymore doing TeamViewer into PC (my default right-click option), you can do the two finger click and it seems to work. 

  • Erica1327
    Erica1327 Posts: 1
    edited July 2021
    Options

    That's very correct solution. When I bought Mac newly, I was even looking for how to do right click and use the menu..