teamviewer.com link icon
or
Ask The Community

Debian Linux: Program does not start

When I start the program I get these messages, but the GUI does not start.

"teamviewer

Init...
CheckCPU: SSE2 support: yes
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
terminate called without an active exception
/opt/teamviewer/tv_bin/script/tvw_exec: Zeile 40: 15540 Abgebrochen             "$TV_BIN_DIR/teamviewerd" -n -f
Network process already started (or error)
Launching TeamViewer GUI ...  "

My system:

Linux xxxxxx 4.13.0-1-amd64 #1 SMP Debian 4.13.4-2 (2017-10-15) x86_64 GNU/Linux

What can I do ?

Answers

  • hello,

    same here (Debian/Buster)

    I'd add that:

    * the gui.log complains about  icui18n (Cannot load library ) despite i have libicu57 properly installed
    * i've tried with either the deb package and the tar archive

    * it's the same with version 11 (deb/tar)

     

    I think it's because of some recent debian upgrades that messed it up. Please teamviewer guys, turn on a Debian/Buster 64b with multiarch option and test one install of teamviewer.

    Have a good week-end ;)

    regards

    f.

     

     

     

  • sbender
    sbender Posts: 1

    try apt install libicu-dev:i386

    I was missing the 32bit binaries.

  • I have a similiar issue when I click on the Teamviewer 14 GUI. It behaves as though it wants to start but nothing...

    Here is my systemctl status, not sure what the PID is complaining about:

    ● teamviewerd.service - TeamViewer remote control daemon
    Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: enabled)
    Active: active (running) since Mon 2019-11-04 13:21:00 MST; 14min ago
    Process: 2080 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
    Main PID: 2082 (teamviewerd)
    Tasks: 13 (limit: 4915)
    Memory: 6.2M
    CGroup: /system.slice/teamviewerd.service
    └─2082 /opt/teamviewer/tv_bin/teamviewerd -d
    Nov 04 13:21:00 buster systemd[1]: Starting TeamViewer remote control daemon...
    Nov 04 13:21:00 buster systemd[1]: teamviewerd.service: Can't open PID file /run/teamviewerd.pid (yet?) after start: No such file or directory
    Nov 04 13:21:00 buster systemd[1]: Started TeamViewer remote control daemon.

     

     

     

    *thanx*

  • yveslec
    yveslec Posts: 1 Newbie

    The message "Can't open PID file /run/teamviewerd.pid (yet ?) ...", is not the problem of no GUI on your graphic session.

    If you check its actual presence with

    # ls -l /run/teamviewerd.pid

    you'll probably see it. It's just a synchronization (that's why you see "(yet ?)"

    ======================

    Personally I get this behaviour, with version 14 or 15 , after I passed my Linux system from default run level 5 (automatic graphic login with KDM) to default runlevel 3, so I have to lauch a graphic session , after an ascci login on console, with

    $ startx &.

    (I do that because I got "come out from suspend mode" which froze, when KDM is activated !)

    In this context teamviewer GUI does not start, if you have no displaymanager running, like kdm, gdm, etc ...

    look the link below:

    Of course there are many other solution to turn around this situation with no displaymanager running. (exposed in forum here)

    One of them is to make a ssh connection on 127.0.01, from a term open in your graphic session, then force DISPLAY=:0.0 instead of localhost:10.0 , set automatically by ssh X11 redirect.

    Then start teamviewer from the same terminal, and then the GUI opens!

    Unfortunately this GUI is then only usable to take control on a remote system. On the reverse if someone tries to take control on your linux, where teamviewer has been started such a way, after entering the ID of your Linux Teamvieser, the remote controler will wait indefinitely the banner inviting him to enter the password !!!!

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!