link icon
Ask The Community

Cannot connect to Pi


First of all, THANK YOU for developing Teamviewer for Pi! It is the perfect fit!

Now, for my issue.  I have a Pi3 running Rasbian. I installed the Teamviewer Host Beta and it runs on my Pi.  I can see everything when I am logged on the the Pi through vncserver. It shows the ID and password.  When I try to access through Teamviewer, using the ID and password provided, it says I have entered the incorrect password. I went to settings and established a unattended password.  I also set it to "accept" incoming LAN connections, since the computer I am using is on the same network (home). Tried to log in, again, to no avail. 

Let me know how to troubleshoot.

Thank you, again, for developing this!


  • ChristianCay
    ChristianCay Posts: 184 Staff

    Dear Bomber1712,

    Thank you for your post.

    Please try to restart the TeamViewer daemon and use the unattended access password to connect to your device.

    sudo teamviewer daemon restart

    That command needs to be run on your device and should fix your issue.

    Best regards,



    Did my reply answer your question? Accept it as a solution to help others, Thanks.
  • I ran the command.  It returned "systemctl restart teamviewerd.service". I tried to log in to the Pi through another computer on my LAN. I got the invalid password error. Is there a command that I should have entered to make sure it starts at "startup"? I typed "teamviewer" in terminal.  It returned: "Init.../xprop:  unable to open display ' '/Checking setup.../Launching Teamviewer.../Launching Teamviewer GUI...After that, it just sits there. I cannot input anything. I tried to log in to the desktop via Teamviewer, but got the invalid password error message.

    The way I have been starting it is to log into the desktop via tight vnc server. Then, I have to actually start Teamviewer to see the GUI.  Under settings>general>display name>raspberrypi and Incoming LAN connections>accept.  Under the Security tab>, Random password>disabled.  I also reset the password to make sure i am entering the right thing.  By opening the GUI AND running the command you suggested, is that running 2 instances? Does the computer ID in GUI differ from the one generated with the terminal command?

    Any other ideas?

  • ChristianCay
    ChristianCay Posts: 184 Staff

    Dear bomber1712,

    Thank you for your post.

    You should not start TeamViewer from VNC as TeamViewer doesn't support Virtual Terminals.

    It needs to start from a physical terminal. Previously there was an issue with switching IDs and passwords that was fixed in newer versions.

    What version are you using? May you please check if you're using the latest build?

    We are looking forward to your comments.


    Best Regards,


    Did my reply answer your question? Accept it as a solution to help others, Thanks.
Sign In or Register to comment.