teamviewer.com link icon
or
Ask The Community

TeamViewer "Not ready. Please check your connection."

TeamViewer 13 is working fine on desktop computer (hard-wired to internet) and Toshiba laptop (wireless), but not on Acer laptop (wireless). TeamViewer used  to work on the Acer some six months ago (it's is an elderly neighbor's computer), but then vanished from my list of partners. I didn't think anything of it when it happened, because I figured the woman just wasn't turning her computer on as often. She's brought her laptop over to my house for me to try troubleshooting, but I get the same message on her laptop here that she was getting at her house (Not ready. Please check your connection.)

There is no problem with the Acer connecting to the internet. I'm able to browse, download email/attachments, and when there was an older version of TeamViewer installed, TeamViewer itself said there was a newer version, and it went ahead and updated itself to version 13.

I tried uninstalling and reinstalling TeamViewer - versions 13, 12, and 8 (I saw version 8 mentioned by someone else who was having this problem, for whom the older version worked). No luck.

Firewall on the Acer is set to allow TeamViewer. Antivirus is Panda, but even if I turn it off temporarily, I still get the "check your connection" message. 

I'm moderately computer-savvy, but I do not know anything about hosts, which I've seen mentioned in other similar threads. Would anyone be able/willing to help me try to resolve this? :manfrustrated:

Best Answer

Answers

  • I'm having the same issue, however, none of the solutions on this form has worked for me as of yet. I've even gone as far as reinstalling the OS on my mac, and it's still the same error on this one and only computer. I'm running Mac OS 10.3.3...

    Screenshot 2018-02-11 09.32.41.png

  • Scotty
    Scotty Posts: 493 Staff member 🤠

    Hi techavenue,

    I believe this has already been discussed with you previously as this is in regards to your license.

    Please contact our support team for more information as this is not an issue that can be resolved in the community.

    https://www.teamviewer.com/en/support/contact/

    -Scotty

    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • This does not work.