link icon
Ask The Community

[Update: 13.0.6634] Christmas Update



  • Thanks for all your hard work on this, it is well appreciated!

    One bug I've noticed is that proxy settings aren't working properly yet.

  • As many ou us mentioned before, it has quite a few bugs in Linux. It's too bad I can't attach a picture here, but the tool bar at the top of the screen has only a couple of very basic options... everything else is missing.

    However, I can connect to a Windows PC without any problem from Mint 18.2.

    Any idea when are you going to release a patch to solve all the Linux problems??



  • AG
    AG Posts: 4

    I agree with you KD1


  • It could be very useful to have tooltips on the toolbar... Also... where did the File Transfer tool go?

  • I hate to complain, but come on.
    Three weeks ago with 13.0.6634 Christmas Update and all has gone quiet. No more updates Daniel? Go over and see if you can borrow a few coders from Linux Mint, or maybe right from here, zeroconf, or ndit. They seem to be able to sort through all of the problems. Maybe things would start moving in the right direction. Sorry... but you need someone to help.

  • arndo
    arndo Posts: 1

    A feature I dearly miss and haven't seen disscused anywhere (not even menitoned in the survey) is the recording of the session. Are there any plans to implement this in the near future?

  • ogio71
    ogio71 Posts: 2

    I think it was a bad idea to release a new version without all functions used before.

    I hope a Wine installation can works, as my customers are updating to rel 13 but i'm unable to connect to them.

    In my Fedora 26 i see a lot of black squares randomly on the screen without a refresh for them.

    I miss also the transfer files function, used a lot in supporting customers.

    Do you think I can install on Linux a wine version of TV 13?

    I think you must works hard in developing a completely new version on a different OS, so it will be a challenge. I hope linux support will continue as before, this was a delta with your competitors.



  • AG
    AG Posts: 4

    Message to Linux mint users.

    Is **Third Party Product** could be a good alternative to TV???

    Actually, I test **Third Party Product** on Windows 7 (with Virtualbox)and Linux mint 18.3 mate 64 bits, and seem to work well in both ways !

  • **Third Party Product** works great for Mint 18.3 and Win 10.

  • frodo
    frodo Posts: 3

    "Still, even with missing features, the majority of our users seems to appreciate the general direction we are going with the Wine-less, native TeamViewer with true 64 bit support and repositories."

    I see TeamViewer 13 has added this:


    name=TeamViewer - $basearch

    No new repository has been added to my OpenSuse Tumbleweed 64 list (in the Yast2 graphical Repo list).  Does the teamviewer.repo file control how teamviewer updates itself when running?  Is the update automatic or do you have to select agree like in the Windows version?

    Seems much more responsive and the display is better.  Looking forward to file transfer and screen resolution coming back as you ad features.  Thanks!

  • frodo
    frodo Posts: 3

    If you update the install instructions at:

    You might add this since yum/dnf is not an OpenSuse option.

    # OpenSuse for RPM packages:
    sudo zypper install ./teamviewer_13.yyy_[arch].rpm
    sudo zypper install ./teamviewer-host_13.yyy_[arch].rpm
    # ./teamviewer_13* works if this is your only matching filename

    Running the above updated my install from 12 to teamviewer 13 on OpenSuse Tumbleweed.  Prior settings worked and this step was no longer needed:

    rpm --import TeamViewer_Linux_PubKey.asc 


  • AG
    AG Posts: 4

    What about DEB packages ?

  • frodo
    frodo Posts: 3

    Teamviewer 12 with OpenSuse Tumbleweed 4.14.12-1 linux kernel on boot (RPM install - not updated, not tested by OpenSuse QA):

    Kernel panic - not syncing ...

    CPU: 1 PID: 2082  Comm: teamviewerd Not tainted 4.14.12-1-default #1

    MSI-7640/890FXA-GD70 motherboard.  I was able to boot from 4.14.8 kernel option.  Disabling Extras-Options- box for "Start Teamviewer with system" resulted in same teaviewerd (daemon) message at boot.

    This worked:

    teamviewer daemon disable 

    Running Teamviewer 12 form 4.14.12-1 kernel froze the system. I upgraded to Teamviewer 13 and all seems good with latest kernel now.

  • ogio71
    ogio71 Posts: 2

    Hi Frodo,

    I appreciate the effort to change the product.

    My concern is related to a product that I decided (with my company) to buy because it is compatible with Linux.

    As we use only Linux for daily jobs (only a virtual machine for those activities that can't be done with Linux only software) we need all functionality on Linux.

    I contest only the choise to have a so different product released for Linux without the possibility to use the old version (it is not compatible with new client) or the new version but in Windows version.

    I think that it can be a transaction period on which we can choise between a native Linux and a Wine version, as we can work as we paid.

    I can be also a beta tester for new versions (but it is a beta).

    Remember also that the new version doesn't work well on my Fedora 26 (even it is declared to be compatible with). If I connect to an old client i see some black square on the screen and no refresh on them even if i pass with the mouse on it.



  • I greatly appreciate all the work you have put in to the full linux version. Unfortunately it is still fairly unusable for me. Lots of black squares on the screen, times where it doesn't want to connect at all, and very annoyingly, the contacts list does not show online or offline. Please release the wine version as a temp workaround until the full version is prime time ready. I am having  to use a VM to run the Windows version just so I can connect to my customers. I finally opt'ed for the yearly subscription you guys have been pushing, instead of just buying a new major release when there were features I needed, and now I have lost my Linux functionality..

  • Zibri
    Zibri Posts: 1

     In the previous versions I could set the zoomed view or fullscreen view...

    Where is that setting in this version? The top bar is different and I don't see it!

  • I'm running TeamViewer on Linux Mint 18.2. There is no option to add "Partner ID" into Your "Computers & Contacts".

  • Please have the toolbar minimized by default.

    Please have the window maximised by default or alternativly remember geometry.

    On the windows version, the new beta layout with one single window is much nicer instead of seperate window for teamviewer and then anothe one for computers&contacts. Would love this on the linux version. except maybe have it so as the recent connections tree can be removed, [ some of us only use TV for a handful of machines and this can make no sense, maybe if total machines is less than X don't show recent connections].

    Lastly a vote towards not worrying too much about wayland. I can't see the sense in running a production machine on wayland at all yet, its still way to early for it. People pushing it as default are crazy or have very different definitions of production ready than I do. Just my 2 cents. Wait until its all done and solid first. To me, TV being bleeding edge is not as important as reliablility.

  • drh27
    drh27 Posts: 3

    I also had to roll back to v12 and keep my customers from upgrading; the critical missing features for me are 1)View Monitors in Separate Windows (which I haven't seen mentioned yet), and 2) file transfer.  While I could live without file transfer for a while, due to my workflow with customers, TeamViewer is nearly useless to me without the opportunity to view remote monitors as separate windows. I found the survey too late to participate. Any idea if this feature is on the list to be restored?

  • M4CC4
    M4CC4 Posts: 4

    Thanks for the great work. Eagerly awaiting the January release and [hopefully] reintroduction of File Transfer, Screen Resolution and Full Screen.

  • globalsi
    globalsi Posts: 4 ✭✭


    In the ad, you talk about a relase planned for January.
    Do you have more details on the release date?

  • treki
    treki Posts: 1

    Work unstable on my Linux Mint 18.2 mate amd64.

    Suddenly Teamviewer13 closes by self.

    Now i have downgraded to TV12.

  • mhb
    mhb Posts: 8

    Really disappointed that file transfer has disappeared, especially after upgrading my Pi so I could use team view for file transfer with it!

    Do you have plans to re-instate this option?

  • This problem exists with me connecting to Windows 10

  • Please make it fully support Wayland soon...  hope to hear good news soon...

  • Dear TeamViewer, tell me please, where can I download the version for Linux, but that it would not be a preview? Preview version it's very very very very very very uncomfortable. The new GUI is very terrible!

  • _Andreas_
    _Andreas_ Posts: 18 Staff member 🤠
  • Right. But older versions can not connect to newer versions.
  • mhb
    mhb Posts: 8

    Indeed the Linux version seems pretty degraded. File transfer and ctrl characters work on windows version but not Linux.  File transfer even works on Android - should be an easy fix.

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    Hi all, we have released a new update: File Transfer & Chat
    @globalsi: today :robotwink:
    @mhb: there you have it

    @Zibri, @muckalo those features should come back with the March or April update.

    @gerry5858: window maximized: done. toolbar minimized: I'd like to have that, too :robotwink: Wayland: accepted. New UI layout: most likely not this year.

    @drh27: Might take a few more releases, I have to check how complicated it is. As a temporary solution, you could start multiple connections, one for each screen.

    All the best,


    Linux Developer