"Window" key does not get transferred to remote machine as "Super" key

I've installed Linux Mint (latest as of today) and Ubuntu (latest as of a month ago), and both do NOT allow use of the Super key appropriately when going thru a TeamViewer session. Both environments are Hyper-V VM's, and both will allow the Super (ie. Window) key to do what it is supposed to do when access thru the Hyper-V terminal session.

Linux Mint will exhibit the Menu when the Super/Window key is pressed on the keyboard thru the Hyper-V terminal session. Ubuntu will show a search menu.

However, then accessing either of the environments via TeamViewer, neither will do anything when the Super/Window key is pressed on teh keyboard. 

Would really love to see this working somehow, even if I need to map something manually.

Note that I've added this same content as a reply to the post at https://community.teamviewer.com/t5/Linux/quot-Win-quot-key-does-not-get-transferred-to-remote-machine/td-p/13560, but I was not sure if that full post would be ignored as it has been marked as "solved", when really it appears (to me at least) that it is NOT solved.



  • Andys
    Andys Posts: 6
    Today I reinstalled my debian machine and surprise, Super key does not work anymore. I don't know why, every other key combinations work. I did the same minimal install with manually installed X and Gnome 3. Same as previous installation. Latest version on TW on both linux and windows PCs. If anyone has any helpful information or ideas, I'd be very grateful for it. Also I removed the 'solved' flag from my post since 'it solved inself before, let's gather around and pray' is not a real solution. :)