link icon
Ask The Community

"Sign in failed. Please check your internet connection and try again."

So I've been trying to get team viewer to work on my Android phone for the last 2 days. When I am at home I can remote into my computer without any problems, but when I connect to the Wifi at work, it gives me the error "Sign in failed. Please check your internet connection and try again." even though I am connected and can view webpages on my phone. I've tried it with my mobile internet while at work and it connects just fine, but I don't have a lot of data to use and would like to use Wifi. Is there a specific reason this might be happening? Do ports have to be forwarded in the router at work? Or is this something I can fix by adjusting a setting on my phone?

Also, a coworker can use team viewer on his android phone to remote into his computer at home (even when connected to our works Wifi), so idk how it's possible for him, but not me.

I checked the event log on my phone and I'm seeing errors like this. " with error 113 No route to host" and " with error 113 No route to host". I'm not sure if that will help.

Any help with this would be greatly appreciated.


  • I have this problem with the Ipad app and I am right next to the computer that I want to connect to.

  • holtek
    holtek Posts: 1

    Using the same wifi internet access point, my laptop has no problem signing in but my android phone using the app is a no-go. There is no issue at all using the free McDonald's wifi down the street. 

  • Etherz
    Etherz Posts: 1
    I'm having the same problem with my new s8. It works do fine as long as there is a wifi connection, but as soon as I turn wifi of or if I don't have a wifi connection it stops working. And goes back to " login failed please check internet connection and try again.

    Has anyone found a solution.
  • starstremr
    starstremr Posts: 1

    This is also happening on the s7 Active. Has any one figured it out yet?

  • Markn74
    Markn74 Posts: 1
    I found by changing my dns server in my router settings I can resolve this issue. May have to do this periodically if issue returns, but has worked for me.
  • Hi .. It is solved for me .. I went to App setting > Teamviewer >> Force stop and clear data 


  • Not workibg do not know why i am shocked i used to use this app it was great but now it is getting worth i am worry abt this but it seems to me that the company is unable to fix this connection bug looking for other applications
  • TR
    TR Posts: 1

    I'm not seeing this path. Can you give more details?

Sign In or Register to comment.