link icon
Ask The Community

Cannot change policy on registered device

I have a device that is assigned to my account where I cannot change the policy.  I have followed the same workflow as with all other devices I've setup, which work fine.  When I try to change it on the management console it says "To assign policies to this device, it needs to be assigned to your account first.".  When I remotely login to the computer, however, TeamViewer says that the device is, in fact, assigned to my account.  The line that says that it's registered, however, is a darker shade of blue and I cannot remove the account assignment to try to re-assign.  This is presumably because I was previously able to assign the policy, and that policy prevents removing the account assignment.  Any idea what happened here or how to fix?


  • I have the exact same problem right now. I assume it's because i had an older computer already assigned to the same account but i removed that before i assigned a new computer to the account.

    I have tried talking with the Teamviewer support, but they only told me what i have already tried. Their final "solution" was to make a new account. Which is a bit problematic becuase it's a work computer.

    So far i still have no idea how to solve this.

Sign In or Register to comment.