TeamViewer 13 & debian 9.3 - NO GUI

I post this bug because i look for solution in others message in this page, but those says problem solved but not  show how to solve.

I have debian Debian GNU/Linux 9.3 (stretch) installed in a 64 bits pc

I installed teamviewer_13.0.6634_amd64.deb

This is the problem

user@debianpc:~$ teamviewer

CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

But nothing happens

next i run

user@debianpc:~$ teamviewer --info

TeamViewer 13.0.6634 (DEB)

TeamViewer ID:
Try restarting the TeamViewer daemon (e.g. teamviewer --daemon restart)

teamviewerd status ● teamviewerd.service - TeamViewer remote control daemon
Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2018-02-04 09:49:52 -05; 55s ago
Process: 26250 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
Main PID: 26252 (teamviewerd)
Tasks: 17 (limit: 4915)
CGroup: /system.slice/teamviewerd.service
└─26252 /opt/teamviewer/tv_bin/teamviewerd -d

I a follow the recomendation using

user@debianpc:~$ teamviewer --daemon restart

systemctl restart teamviewerd.service
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Se requiere autenticación para reiniciar 'teamviewerd.service'.
Authenticating as: root

and again the same, no GUI started when I run teamviewer command

I am using awesome window manager

user@debianpc:~$ awesome -v
awesome v4.0 (Harder, Better, Faster, Stronger)
• Compiled against Lua 5.1.5 (running with Lua 5.1)
• D-Bus support: ✔
• execinfo support: ✔
• RandR 1.5 support: ✔
• LGI version: 0.9.1

extra pc inf

HP Compaq Pro 6300 SFF
Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
256KiB L1 cache
8GiB System Memory
4GiB DIMM DDR3 Synchronous 1600 MHz (0,6 ns)
4GiB DIMM DDR3 Synchronous 1600 MHz (0,6 ns)
Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller
Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
7 Series/C210 Series Chipset Family USB xHCI Host Controller
7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode]
7 Series/C216 Chipset Family SMBus Controller

I hope someone can help please.







Best Answer


  • DamienCassou
    DamienCassou Posts: 6 ✭✭
    I have exactly the same problem (with exwm as window manager)
  • Hi. The solution changed the way that I work.
    I installed ligthdm following an answer
    That's all