link icon
Ask The Community

Please check your internet connection + no ID

Hi  -

I was using TeamViewer for Business with a recent Company and I am now no longer working for them.  I used TV previously for private use at home.

Now I can't seem to downgrade my license.  When I open TeamViewer it just says "Not Ready Please check your connection" and it gives me no ID and Password.    I've tried uninstalling and reinstalling and I am still getting the same error.

Do I have multiple problems here or is this all account related?



  • mLipok
    mLipok Posts: 778 Star

    This is not related to licensing system.
    EDIT: It was looking like it was not related to licensing system.

    I have active Premium license and currently have the sam problem (just submited error log to HelpDesk ).

    I had similar problem - currently works OK just after restarting system.
    But the main problem was that I try to turn of all AV / FIreWall and also closing runing TV again, nothing was succesfull.

    I already had the same scenario few times.

    Still waiting for response from HelpDesk - about my logs.


    mLipok , AutoIt MVP
  • Scotty
    Scotty Posts: 494 Staff

    Hi sitravelgroup,

    This is license related.

    Can you please contact our support team if you need more information.


    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • mLipok
    mLipok Posts: 778 Star
    I just changed my post.
    I apologize for the erroneous diagnosis.
    mLipok , AutoIt MVP
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!