link icon
Ask The Community

TV on iMac Sierra asks for password for helper tool and crashes

I installed latest version on almost new iMac, Sierra. When I start Teamviewer I get a popup sayng it needs my password to install a Helper Tool. It acepts the password, the icon bounces on the dock a few times, and then disappears. 

I've tried to re-install several times. No luck. Tried in safe mode. No luck. 

What is the problem! HELP!


  • Al77
    Al77 Posts: 3

    I made the above post here and created a support ticket for the TV system people. 

    I got no response on either so I simply ran (some with 'sudo') the following :

    rm -rf /Applications/
    rm -f /Library/LaunchAgents/com.teamviewer*
    rm -f /Library/LaunchDaemons/com.teamviewer*
    rm -f /Library/Preferences/com.teamviewer*
    rm -f /Library/PrivilegedHelperTools/com.teamviewer*

    and then downloaded and installed the previous TV version (11.x) on my iMac (Sierra) and it works again.

    If you are running Sierra, you might wait to install version 12 of TV because there obviously are some issues with it. 

  • I am having this same issue. Could you possibly explain exactly what you did to resolve?

    I won't say I am Mac Dumb, but I need a little more direction if you could.

    Thank you so much. 

    Frustrated user. Well, was a user until I tried reinstalling after a crash, now I'm a wish I could user.


  • Al77
    Al77 Posts: 3

    Open up the Terminal App from Finder, Applications.

    Enter the commands above. 

    If some do not work, enter the word 'sudo' before them followed by a space and the command. It will ask for your password and then will execute the command. Once they are all done, re-install TV. 


  • Thank you so much! I am going to give that a try.

  • That worked for me! Thank you very much. The helper tool thing still popped up after installation, but this time it allowed me to enter my password and continue the installation.

    Great Help!!

  • tmking86
    tmking86 Posts: 2 ✭✭

    I have been trying off and on for months to get the installation issue resolved on my macbook air (OS Big Sur). It was nothing less than exasperating. I found this solution and it actually worked!!! Thank you so much AI77

Sign In or Register to comment.