Protocol negotiation failed

On Monday, I was able to successfully connect to my Windows 7 laptop from my Samsung Galaxy Tab 3 tablet using TeamViewer (TV). On Tuesday, I could not connect and Teamviewer on the laptop showed Incoming Connection then a Protocol Negotiation Failure message.

The tablet said that the connection was disconnected and tried to reconnect but never could. At the time, I had TeamViewer 10.0.93450 installed on the laptop. I am able to successfully connect to my Windows 8 desktop PC from the tablet, but I am having the same issue when I attempt to connect to the laptop from a Kindle Fire and an Apple iPad, so the problem is clearly only with communication between the laptop and the tablet.

I have tried the following to resolve this error, and none worked:

  • Restarted TV
  • Reboot the laptop
  • Reboot the tablet
  • Uninstall and reinstall TV on the tablet
  • Install the latest version of TV on the laptop
  • Ensured IPv6 disabled
  • Disabled the firewall
  • Disabled my antivirus
  • Configured TV to allow all Windows logon for all users
  • Configured TV for use with and without UDP
  • Uninstalled every update applied to my laptop in the month of February
  • Restarted the laptop in safe mode with networking and tested, with the same result

I am now seriously considering rebuilding my laptop, but I would reallky like to NOT have to do that, especially since I do not know that it will fix the issue. If anyone has any ideas for me to try, I would very much appreciate it.