link icon
Ask The Community

Stuck at "initializing display parameters" after closing RDP session

It has something to do with RDP, because I CAN connect when I'm connected via RDP (but TV won't let me do anything due to active RDP session). When I close the RDP session TV just hangs on "initializing display parameters" when I try to connect. I'll try to reboot the machine later I guess, but all worked flawlessly until I tried using RDP.

Any ideas?


  • CWebb
    CWebb Posts: 1

    Having the same issue on multiple machines (servers) Any resolution?

  • Did you ever get this resolved? I am having the same issue with multiple machines.

  • No solution, I just stopped using RDP.
  • Scotty
    Scotty Posts: 492 Staff member 🤠

    Hi Everyone,

    There is more information about this issue in our article "TeamViewer on Windows servers"

    Long story short,
    When you connect via RDP, windows Servers begin outputting a display. When you disconnect, the system is no longer generating a display for TeamViewer to capture.

    This can also be the case with some headless systems in some scenarios.

    It comes down to RDP has the ability to force a display output whereas TeamViewer does not and Windows do not have it in their API for us to access unfortunately.

    I hope this answers your question.


    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • Does your comment mean it works after a reboot until you use RDP?

  • Daemach
    Daemach Posts: 1

    What does this mean?  Teamviewer doesn't work?

  • tmib03
    tmib03 Posts: 1

    What this means is, if you connect to a machine via rdp, then do not log off, just end the session, or minimize the rdp session, you will not be able to access your remote machine via teamviewer, you'll have to rdp into the machine again so the display is up, then teamview into it.

  • hoogw
    hoogw Posts: 3

    I solved the same problem by disable screen saver, disable any kind of standby.

    Teamviewer only connects when a monitor is attached and display is on, so to say screensaver or power save are the cause. As soon one uses the system, it wakes up, and so the display, and teamviewer does work again.

    i think it's because mainly teamviewer cannot wake up the screen, so if the screen went to standby mode, teamviewer will not initialize the display.

    the only fix i could find in this is to keep your display awake at all time. disable it from the power settings to never turn off display.

    ( Off course, you can turn off the power button on your monitor, but on unbuntu, you must disable screen saver and disble turn off display after 10 min, keep display on all time)

    This is the ultimate solution. 


Sign In or Register to comment.