link icon
Ask The Community

teamviewer sign on doesn't work - has a bug

When I try to use the sign in on the right hand side to permanently sign on to team viewer so I don't have to keep entering the generated ID and password I keep going around in a circle.

It says I need to add the second computer to trusted devices which I do and click the authorisation in the email. But then when I go back to team viewer to sign on I get the same error that I need to add it to trusted devices.

I have proof of this in the screen captures which I attached below. You can clearly see from the time in the bottom right corner that I am getting the same error message after adding to trusted devices. This is clearly a fault and bug with teamviewer.

When I go to the website to log on there it also says I need to add the browser to trusted devices. I keep going around in the same catch 22 circle and there doesn't seem to be any way to log in to teamviewer even after adding all these to trusted devices.

This seem to be a bug with the software.

You can only use the temporary generate ID and password.

Teamviewer must be aware of this and know about the problem as it has been this wasy for a number of years now and still has not been fixed. They seem to not care and are only concentrating on non-private use paying customers. This is not a good way to help get more of these types of customers by ignoring ones who could potentially become so.

device successfully added.pngstill doesnt work.png


  • Scotty
    Scotty Posts: 492 Staff member 🤠

    Hi john10001

    Honestly, to begin with this whole message is mostly unnecessary and I will ask you to please keep your topic to the point. There is no reason to insult the software and our staff because you have an issue and this does not increase the likelihood that we will assist you.

    Secondly, the trusted devices feature has not even existed for multiple years, so this statement is false. And lastly, the screenshots do not prove much at all, the issue would be much more widespread if there was an actual bug.

    Now, to fix your issue, can you please PM me the rest of the screenshots. ie, screenshot showing your TeamViewer Software with the ID (You can erase the password), a screenshot of the email including time received and also a screenshot of the link BEFORE you press "Add device".

    Please do not post this in the board, please only post this to me in PM as we do not want your TV ID broadcast.

    Thank you.



    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
Sign In or Register to comment.