teamviewer.com link icon
or
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳


Please find more information here.

Copy and Paste does not work

We just bought enterprise, and it's a deal breaker if we can't copy and paste from the Windows 10 host into the TV window. 

I've tried with Sync clipboards checked, and unchecked. I've restarted TV multiple times with both options. 

It does not work. 

Is there a fix for this or do we need to cancel our account to find something which has this feature?

«1

Comments

  • Scotty
    Scotty Posts: 492 Staff member 🤠

    Hi rackattack

    Thanks for posting.

    Unfortunately, this is because the remote side does not have a clipboard at login.

    Copy-Paste works by keeping the clipboard synchronize between the two sides. when at the login screen, there is no clipboard at the remote side so there is no synchronization and copy-paste will not function.

    Unfortunately clipboard synchronization is only available when there is a remote clipboard to synchronize to.

    -Scotty

    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • jsmosier
    jsmosier Posts: 1

    Instead of worrying about syncing the clipboards, how about a command/keyboard shortcut that will "type" the text that is in the clipboard of the remoting computer?

  • Something is not accurate.  When I went from version 12 to 13 (after using 8,9...), something broke in the copy and paste.  I've not been able to do this since version 13 was installed.  

    I've gone back to 12 to avoid spewing venom at every screen, but now I can't connect to my version 13 PC's.  This is very frustrating!!!!!

    If the program does not function correctly, at least give us the ability to connect to newer versions from older versions if we are continuous licensed users!!!

    Yes, if you'd like to call me, please do.

    St** [deleted by moderator]

  • If it helps, I had same issue and configured the remote PC's TeamViewer account to automatically log-on Windows sessions for connections from my TeamViewer account (Extras / Options / Security / Windows logon ... And then whitelist yourself.)... I'd be curious to know if anyone reading this knows of a reason NOT to just take this approach (in a sense, I guess it's delegating local security to your TeamViewer account's level of security?)

  • Please disregard this tip; it is not working as expected.

  • jgt1942
    jgt1942 Posts: 22

    Scotty, how do I activate the clipboard at login? I connect to family members that are all running Win10 x64. On my wife's PC I cannot copy something to the clipboard on my system (local, it is a desktop) and paste it into her PC (remote, it is a laptop) whereas I can do this when I connect to my laptop and it is the remote PC.

    On her PC via TV I can copy something on her PC and paste it into something on her PC.

     

  • jgt1942
    jgt1942 Posts: 22

    I just rebooted both systems and like magic, it is now working.

  • upatrono
    upatrono Posts: 6 ✭✭

    It is not only duting TV sessions. For example even when TV session is not active and it is running as a startup service, my clients cannor Ctrl+C and Crtl+V, when the service is stopper you need to Crtl+V twice in order for it to work. When you completeli shut down TV on the host then everything works ok. 

    Not entirely sure if its related but I've observed this on All-In-One desktop computers so far.

  • adisharr
    adisharr Posts: 4

    I frequenly clip images from PDF's and other documents into my main PC's desktop clipboard and paste them into emails on my laptop (in Outlook) connected over Teamviewer 14.

    This used to work fine but recently (past few days), image pasting stopped working. I'm able to copy and paste files and text fine but when I try and paste an image it's just pastes the last thing in the clipboard instead.

    I know the image is in the clipboard because I can paste it into other spftyware on the main machine. I've tried snipping tool and also a thriud party program (FastStone image capture).

    Nothing has changed as far as I know on my end. The clipboard sync is still checked on both machines and I tried rebooting both as well.

    Any ideas?

    This has happened before and then just started working again.

  • I'm having the same issue.

  • SPIRALE
    SPIRALE Posts: 1

    Hello,

    I'm a TeamViewer user for a long time and I switched to version 14 recently. even if my version 10 worked perfectly... I use Host version and WINDOWS 10...

    I have a big problem with the V14 since 2 weeks at least : I have some problems to copy/paste a picture from my local computer to my remote computer. It tells me that the clipboard doesn't have good data... but it's very strange : it's working one time and it's over...

    This morning, I make some new tests while I'm writing this post :

    - Copy/Paste from my remote host to my local host works perfectly (I don't use this way)

    - I used WORD for the tests to eliminate software problem (I usually use a SAGE software on my remote computer).

    - After the copy/paste from my remote host, "copy" action from my local host is not detected on my remote host. I make a copy/paste with simple text data from my local host : it's working, then I copy a picture and make a paste on my remote : the text is still copied. 

    - After a reconnection, remote clipboard remains empty even if a picture is copied on my local host.

    Very strange,...

    If someone can help me...

    Best regards,

    Laurent.

     

     

  • I have also the same issue

  • TBH
    TBH Posts: 1

    I also have the same issue

  • But how does the remote computer suddenly loose its clipboard?  It was working the day before.  It was working for the whole year and the year before that.  Now it doesn't.  Any idea what could have changed?  It feels like something went wrong with the recent TeamViewer 14 update.

    In advanced options, Syncronize Clipboards is checked on both computers.  And I can copy-paste text just fine.  Just not images, neither from Paint.exe, nor from the Snipping Tool.  Can't do it in either direction.

  • I experienced the same behavior.

    Copying text works

    but copying images bitmaps (not files!) from host to client doesn't work anymore

    since I upgrades the Host Temaviewer Software from V13 to V14 yesterday.

    I need this feature for copying screenshots from snipping tool into reports.

  • maxnett
    maxnett Posts: 1

    +1 on this.

    That's how many other remoting systems get around this issue. For example Microsoft Virtual Machine Manager, and RoyalTS both have a "Type Clipboard" button, which will simply send the contents of the clipboard to the remote machine as a stream of characters, one by one.

    You would have thought TeamViewer would implement something along these lines, given the scale of their operation and price of licensing? 

    RoyalTS:

    type-clip1.jpg

    Microsoft Hyper-V Manager:

    hvm.jpg

    Cheers, Matt

  • I reverted back to v13 and copy/paste of images is now working again.

  • adisharr
    adisharr Posts: 4

    Great, I'll try that as well. I'm glad the community tries to answer these questions as Teamviewer must be busy with their larger clients.

  • Kerstin_PO
    Kerstin_PO Posts: 58 Staff member 🤠

    Hello community users,

    thank you for all your messages and feedback.

    We are currently analysing why images can no longer be copied & pasted and we will fix the problem it as soon as possible. I'll keep you up to date on the progress.

    Sorry for the inconveniences!

    Best,

    Kerstin

    Product Owner TeamViewer Core
  • Kerstin_PO
    Kerstin_PO Posts: 58 Staff member 🤠

    Hi to all,

    good news for the copy&paste bug for images: we have found the problem and fixed it (it was introduced with version 14.2, so if you immediately need a fix going back to 14.1 for the moment should be sufficient).

    The fix will be released with the next Insider build (if you have access to that) and with the next public 14.3 release, of course.

    As there are several topics mentioned in this thread, I'll also take the "type clipboard" shortcut as a feature request with me.

    Have a nice day!

    Best, Kerstin

    Product Owner TeamViewer Core
  • Where can we download Version 14.1?

    I doesn't find the Version here: https://www.teamviewer.com/en/download/previous-versions/

  • Esther
    Esther Posts: 3,880 Community Manager 🌍

    HI @franatech_tk 

    Please find TeamViewer 14 here: https://www.teamviewer.com/download

    Thanks and best, Esther

    Community Manager

    Support us on Trustpilot.
  • adisharr
    adisharr Posts: 4

    That points to the latest version, where would 14.1 be?

  • This was my question

  • Esther
    Esther Posts: 3,880 Community Manager 🌍

    Hi all,

    sorry - my mistake!

    Please find the 14.1.18533 here: Download TeamViewer 14.1

    Thanks and best,

    Esther

    Community Manager

    Support us on Trustpilot.
  • BB
    BB Posts: 4

    As of Today (June 12, 2019) this isssue is still not resolved. I reverted to an earlier version to resolve this. I hope they can resolve this basic functionality soon.

  • Still going on here, and the downgrade link above no longer has anything available. 

    This is the biggest reason I'm having trouble dropping ScreenConnect. This and the remote toolbox.

     

  • Arahiko
    Arahiko Posts: 1

    As well as the copy and paste not working, has anyone been having trouble with the Transfer files action?

    I have tried sending passwords/product keys etc via the Transfer action but it doesnt work either, so I have to maually enter a 25 character code manually, its just not on.

    They say the fix is to go back to V14.1 but then remove the link? is that becayse V14.1 has the same bug?

  • Esther
    Esther Posts: 3,880 Community Manager 🌍

    Hi @GrumpyITGuy 

    I updated the above download link. It is working again.

    Thanks and best, Esther

    Community Manager

    Support us on Trustpilot.