link icon
Ask The Community

TeamViewer 13 unattended access UAC prompt

I am using TeamViewer 13 "Personal" (free) to remotely support my family.

I originally set this up using TeamViewer 11. All remote machines have TeamViewer installed and set to run at startup - I set them all up for unattended access and assigned them to my TV account. All computers are Windows 10 and all of the user accounts are local user accounts except for the account I use for admin. In other words, none of my family have admin privileges, just me.

This worked great for a long time and I was able to remotely do administrative actions, such as run "services as administrator" and start/stop services. If I took an admin action while fixing something in a local user account, I could see the UAC prompt. This allowed me to fix issues in their account while they were presently logged on. Also, I could also switch users to get into my admin account, so no user needed to be present.

As a quick note, I do not think I was using Windows Authentication for this. I would just sign into my TeamViewer account through the application. I would see the computers in my list and connect to them. I have 2-factor installed, so I'd enter my 2-factor code and I'd have full access.

Some of my family members updated their TeamViewer from 11 to 13. Their computers were still listed in my TV account, but I needed to start connecting to them using TV13 instead of TV11.

However, now when I do an administrative action triggering a UAC prompt, I (the remote user) get a message like "Your partner's desktop is no longer accessible. Probably you used a program that requires additional permissions. Please wait until your partner has granted these permissions". My family (the host) has told me that they see the UAC prompt with my admin name waiting for a password - but all I see is that message. Since they don't know the admin password, they cannot enter it.... and since I cannot see the prompt I cannot enter it.

Further, if I try to do a switch user to get my admin account I get this message "The screen cannot be captured at the moment. This is probably due to fast user switching or a disconnected/minimized Remote Desktop session."

This has removed all ability for me to remotely support my family for anything requiring admin access.

I have tried uninstalling TeamViewer 13 and reinstalling 11 on their computers. That did not work - a setting seemed to remain after uninstall.

I have tried reconfiguring unattended remote access, but that didn't seem to work either... though I may have missed something when I was trying this.

Any suggestions on how to fix these issues would be helpful. If no one has a suggestion on how to fix the issue, can someone tell me how to completely remove TeamViewer (and all TeamViewer settings) so that I can start from scratch?


Sign In or Register to comment.