TV13 in ubuntu 14.04 64bit error. "Not ready, Please check your connection"

Hi everyone,

I have installed tv13 64bit (teamviewer_13.1.3026_amd64.deb) and this is my first attempt to run teamviewer in linux ever. The OS is ubuntu 14.04 64bit.

there are dependency errors (with Qt5) and I could not see the teamviewer window at all. I "fixed" that by installing Qt5 (5.10.1 to be precise), and starting teamviewer with the following line:

LD_LIBRARY_PATH=/opt/Qt5/5.10.1/gcc_64/lib/ /opt/teamviewer/tv_bin/TeamViewer

you'll notice I start the executable directly from the installation directory.


The teamviewer windows pops up now, but I get this messages in the command line :

failed to get the current screen resources
QXcbConnection: XCB error: 173 (Unknown), sequence: 175, resource id: 87, major code: 150 (Unknown), minor code: 20
WARNING: Application calling GLX 1.3 function "glXCreatePbuffer" when GLX 1.3 is not supported! This is an application bug!
QSGContext::initialize: stencil buffer support missing, expect rendering errors

Not sure if these are related to my issue though.

Also if I run the usual teamviewer script

LD_LIBRARY_PATH=/opt/Qt5/5.10.1/gcc_64/lib/ /usr/bin/teamviewer

I will get the following output

CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
Network process already started (or error)
Launching TeamViewer GUI ...

In both cases the GUI will be loaded and the edit boxes will be disabled because of the error "Not ready. Please check your connection" .

2018-03-23 13_09_40-NX - nass@DAS2_1024 - das2linux.png

it may be that the teamviewerd deamon is not running , so I tried starting that as well, but I do not see it running when I check running processes in linux with

ps aux | grep -i teamv

I only see the GUI running.


Anyone knows of any remedies ?

Thank you in advance for your help