Team Viewer 11 on Ubuntu 18.04

I have a license for Team Viewer 11 and I'm trying to get it to work with Ubuntu 18.04.

Thus far, I have managed to get it installed, but the GUI crashes on startup. The daemon seems to be running fine.
Below is a log from the crash:


I had to install manually libpng12 from source to meet the installation dependencies.

Any idea what is going wrong?

Best Answer


  • ericward
    ericward Posts: 1
    I too am having numerous problems with getting TeamViewer 11 to run since Ubuntu upgraded to 18.04... I have tried several "fixes" suggested and even switched from Unity to GNOME which gave me less errors, but still no luck making it load. No errors nor response when I click on the icon to launch, however typing "teamviewer" in terminal gets me this:
    > Init...
    > XRandRWait: No value set. Using default.
    > XRandRWait: Started by user.
    > Checking setup...
    > Launching TeamViewer ...
    > Launching TeamViewer GUI ...
    and then nothing. No TeamViewer window, no icon in the system tray (if that is the proper term for Ubuntu's top bar). Not even a prompt because it finished loading.
    Things I have tried:
    > installing and reinstalling (with dpkg and gdebi and gdebi-gtk)
    > adding the i386 architecture
    > installing gtk3-nocsd and
    > installing the 64bit version
    > updating and upgrading (even though the upgrade to Ubuntu 18.04 is what messed it up)
    > autoremoving
    > removing both config and local share teamviewer directories and files
    > running as sudo and su
    > update-rc.d teamviewer defaults
    > copying the script from the opt folder for TeamViewer to the init.d folder for TeamViewer
    > daemon start
    > enabling teamviewerd.service
    > looking for the man file and finally finding command line options
  • zardoz
    zardoz Posts: 2

    I have the same issue. Is there a solution?

  • gbt
    gbt Posts: 1

    We also have a valid TV11 license, and would very much like to keep using it. It works on 16.04 (the previous LTS), but not on 18.04 (the current LTS). So far nothing we tried works with 18.04, just like the other posters we tried many many possible workarounds, but without success...

  • kapn1966
    kapn1966 Posts: 1

    Ditto. Seems we're not likely to get an answer.


  • cbraxton
    cbraxton Posts: 1

    I have the same problem, a TeamViewer 11 licence and running Ubuntu Linux as my primary OS. Updating to Ubuntu 18.04 broke TeamViewer.

    I have not found a solution but came up with a workaround - a Windows XP virtual machine running under Virtualbox, using an old leftover XP license key.

    TeamViewer 11 works just fine this way and XP doesn't take much in the way of resources by today's standards. (I'm using 192MB memory and 5GB disk for my XP virtual machine.)  You could  run an older version of Linux in a virtual machine instead if you don't have a suitable XP key and disc handy.

    Obviously it would be preferable to run TeamViewer directly but at least it's functional this way.

  • teocci
    teocci Posts: 1

    Probably you can fix it using this commands:

    sudo rm -rf /home/user/.config/teamviewer*
    sudo rm -rf /home/user/.local/share/teamviewer*
  • cmk-md
    cmk-md Posts: 1
    sudo rm -rf /home/user/.config/teamviewer*
    sudo rm -rf /home/user/.local/share/teamviewer*

    Don't work

  • koopee
    koopee Posts: 2
    Greatly appreciated! Thanks! I uninstalled with apt remove --purge. Did not clear anything specific besides that. Also when copying libfreetype, changed the owner/group to root. I don't know if owner change was necessary or not.
  • Glad it works for you!

    As you say, the "cleanning" part is not strictly neccesary in all situations but I just added it to prevent that one of our old attemps to resolve the problem cause some inconvenient.

    Also, yes, for copy the files into the teamviewer folder you will need elevated priviliges.

    I forgot to comment: this workaround is also suitable for Linux Mint 19 (being based on Ubuntu 18.4) and maybe for Teamviewer 12 but I do not test this.




  • Definitely doesn't work withTV 14, I just tried it.