Missing dependencies on CentOS 7.4

malmax66 Posts: 4 ✭✭


I've tried to update my TV from 12 to 13, but I always run in troubles with missing dependencies. My machine is a CentOS 7.4 (just updated), EPEL an CR are enabled, but when I call

yum install

I get following errors:

Abhängigkeiten werden aufgelöst
--> Transaktionsprüfung wird ausgeführt
---> Paket teamviewer-host.x86_64 0:13.1.1548-0 markiert, um installiert zu werden
--> Abhängigkeit libQt5WebKit.so.5()(64bit) >= 5.2 wird für Paket teamviewer-host-13.1.1548-0.x86_64 verarbeitet
Loading mirror speeds from cached hostfile
* epel: ftp.nluug.nl
* fasttrack: mirror.maeh.org
--> Abhängigkeit libQt5WebKitWidgets.so.5()(64bit) >= 5.2 wird für Paket teamviewer-host-13.1.1548-0.x86_64 verarbeitet
--> Transaktionsprüfung wird ausgeführt
---> Paket qt5-qtwebkit.x86_64 0:5.6.2-1.el7 markiert, um installiert zu werden
--> Abhängigkeit qt5-qtbase(x86-64) = 5.6.2 wird für Paket qt5-qtwebkit-5.6.2-1.el7.x86_64 verarbeitet
--> Abhängigkeit qt5-qtdeclarative(x86-64) = 5.6.2 wird für Paket qt5-qtwebkit-5.6.2-1.el7.x86_64 verarbeitet
--> Abhängigkeitsauflösung beendet
Fehler: Paket: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
Benötigt: qt5-qtdeclarative(x86-64) = 5.6.2
Installiert: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (@base)
qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
Fehler: Paket: qt5-qtwebkit-5.6.2-1.el7.x86_64 (epel)
Benötigt: qt5-qtbase(x86-64) = 5.6.2
Installiert: qt5-qtbase-5.9.2-3.el7.x86_64 (@base)
qt5-qtbase(x86-64) = 5.9.2-3.el7

Where is a repo to get the missing files from or is there a possibility to get a tar-archive with TV packed together with the dependencies?



  • malmax66
    malmax66 Posts: 4 ✭✭

    Hi @LL

    I found a solution:

    Download the qt5-qtwebkit in a previous version, e. g. 5.9.1 from this URL in this way:

    wget http://dl.fedoraproject.org/pub/epel/testing/7/x86_64/Packages/q/qt5-qtwebkit-5.9.1-1.el7.x86_64.rpm
    yum localinstall qtwebkit-5.9.1-1.el7.x86_64.rpm

    Afterwards you can download the TeamViewer-rpm and install it by using

    yum localinstall teamviewer_13.1.3026.x86_64.rpm

    This way works :)

  • malmax66
    malmax66 Posts: 4 ✭✭


    I'm using CentOS 7, it's a RPM-based system. When I tried to install I got the message I posted above with the list of missing dependency. It took a little bit of time for checking all dependencies before it cancelled the installation.

    It was necessary to install the missing file in a previous version before all dependencies were fullfilled. Afterwards TV 13.1.3026 was working fine!

  • rennrad
    rennrad Posts: 1

    The same error above appeared for me running centos 7 after attempting to

    yum localinstall teamviewer_13.1.3026.x86_64.rpm

    Therefore  attempted your solution and found a typo....it should be :

    yum localinstall qt5-qtwebkit-5.9.1-1.el7.x86_64.rpm

    teamviewer is now running ok on centos 7 for me.

  • zari
    zari Posts: 1
    Hello friends, I really need help. When installing teamviewer 13 on ubuntu 17.10, or elementary os, the same problem appears. There is no demonstration mode. I'm completely confused and do not know what to do. I reinstalled the system, reinstalled the teamviewer but nothing helps.