raspberry pie team viewer with same password

Everytime the rapsberry pi teamviewer session is restarted, it ask for a different password,.  How can i make it use just one password?    I know i can leave it open and make a note of the session password  but today the power went off and i couldnt log back in on it.  Please help? 

Best Answer


  • ChristianCay
    ChristianCay Posts: 182 [Former Staff]

    Dear resolver101757,

    Thank you for your post.

    We recommend you to set a personal password and disable the random password feature.

    To do so, go to TeamViewer options \ Security

    Click 'Change password' and type the desired one.

    Select 'Disabled (No random password) option for 'Password strength'

    Then click OK. After that, you should be able to connect using the same password always as a long as you don't change it to a new one.

    Any other questions please don’t hesitate to contact us.

    Best regards,


    Did my reply answer your question? Accept it as a solution to help others, Thanks.
  • I've tried this but it still doesn't seem to work.

    Once I reboot the Pi, the password I set is no longer the password it's expecting.

    Once I go in and re-set the default password, I can access it till the next reboot.  It also doesn't remember the Display Name I have entered into the Config as well.  Oddly, though, it does remember my selection to disable the random password.  That said, I don't know how it's generating a default password if that option is disabled.

    Is there any place I can otherwise hard code this?  (Please bare with me as I'm a Linux / Pi newbie.)

  • essdeeay
    essdeeay Posts: 3

    +1 for this problem.

    Incidentally, the first few reboot after installing TeamViewer, the ID aswell as the password changed, but the third ID seems to be the same now.

  • HanZ
    HanZ Posts: 1

    I have exactlythe same problem.It drives me crazy. Tried via teamviewer passwd XYZ as well as per GUI, both wont work,

  • ABQ_RPi
    ABQ_RPi Posts: 3

    I have the same problem, every time I boot the RPi, the Teamviewer ID and password change. If I assign a password for remote access, it disappears on the next boot.

    This is a brand new Pi V3, with new NOOBS 2_4 Raspian installed and updated. There is something wrong with teamviewer-host_12.0.76958_armhf.deb


  • essdeeay
    essdeeay Posts: 3

    Update on my post a few back...

    raspbian - Linux raspberrypi 4.4.50-v7+ #970 SMP
    TeamViewer Host 12.0.76958 (DEB)

    I spoke to TeamViewer support on the phone and had them login to do some testing on my machine. They also saw the problem and couldn't fix, said for me to open a support ticket.

    Some things I know and can reproduce...

    • It affects raspbian, but does NOT affect Ubuntu MATE
    • After a clean install, the TeamViewer ID changed after each reboot for 4 reboots only. After the 4th different TeamViewer ID, it now remains static
    • The static password is retained (OK) after a service stop/start
    • The static password is lost (or doesn't save) after every reboot
    • The random generated password always works, but you have to log into the console to see what it is (defeating the object of having TeamViewer as a service anyway)
    • If you restart the teamviewer service, incoming LAN connections are no longer possible

    So, I don't think the problem is going to get resolved in the community forums - these are reproducible problems and should probably go straight to their support desk... as I will do now.

    Many thanks,



  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    Hi everybody,

    thanks for your feedback. First let me try to clarify: From the wording, I think resolver101757 did not set a permanent password. For all you others: We know about the problem and currently try to find out where it comes from. I'm currently suspecting that it only happens with recent installations of Raspbian, as our Test-Pis are not affected. Essdeeay's comment about Rasbian vs Ubuntu also points in that direction.

    In general, essdeeay's is also right about that the problem can hardly be resolved by the community. However, if somebody has a hint like "it works on my image from last year, but not on the one I created in February", that might help us.

    You are free to create support tickets, but I doubt it will speed up the process, as by now we have enough reports. It rather might slow us down if we have to answer many tickets. But definitely create one or comment here if you have valuable information to help us reproduce the problem.

    I'll keep you updated on this.

    Thank you!


    Linux Developer
  • essdeeay
    essdeeay Posts: 3

    Hi Daniel,

    Thank you for the information posted in your reply - very helpful. I did submit a support ticket (#3159867), with a lot of information about how to produce, and also the logs. I suspect it's a permissions problem with the service reading certain files, but I'm not savvy enough to work that one out!

    Good luck with the ticket!
    Steve :)

  • lchiorazzi
    lchiorazzi Posts: 1

    Same issue here...just installed 2017-04-10-raspbian-jessie.zip and Partner ID and Password will NOT save.

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    Please have a look here for updated information on the issue:

    Raspbian: Password and ID problems

    Linux Developer