teamviewer.com link icon
or
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?


Download the new version and let us know what you think about it! 👉 Please click here 👈

Teamviewer 13 not connecting in Ubuntu 18.04 Login Screen

I installed Ubuntu 18.04, and I noticed that in the Login Screen Teamviewer (teamviewer_13.1.3026_amd64) is not connecting.

However, when I log in then Im able to use Teamviewer.

I didn't have this issue with Ubuntu 16.04 and teamviewer_13.1.3026_amd64.

 

Comments

  • beduoin
    beduoin Posts: 1

    I'm having the same issue. I can log in, but won't connect to host.

  • Smeg
    Smeg Posts: 1
    I get a similar issue. After reboot, I cannot connect via Teamviewer.

    Following manual login, Teamviewer is able to connect at the login screen until the next reboot.
  • dtstanton
    dtstanton Posts: 11

    Same here. On Ubuntu 18.04 bootup, Teamviewer 13 does not start. Starts after login.

  • Esther
    Esther Posts: 3,978 Community Manager 🌍
    Hi there, thanks for the hint. I removed beaver from the filter.

    Best, Esther
    Community Manager
  • dtstanton
    dtstanton Posts: 11

    That worked. Thank you!

  • LowKi
    LowKi Posts: 1

    That workaround link is 404.. can someone transcribe post relevant information?

  • Hi, 

    Links are 404 because Teamviewer forum didn't allow me to write full urls as in their content have beaver word.

    https:// linuxconfig.org/how-to-install-teamviewer-on-ubuntu-18-04-bionic-**bleep**-linux
    Substitute the **bleep** by beaver word.

  • <TL;DR>

    sudo gedit /etc/gdm3/custom.conf

    Uncomment this line in custom.conf file:

    WaylandEnable=false

    and Reboot.

  • 905jay
    905jay Posts: 1

    I can confirm with TeamViewer 14 and Ubuntu 18.10 that this works

  • Jocafi
    Jocafi Posts: 1

    Thanks bobgutierrez.

    It solved the problem on my Ubuntu 20.04 LTS and TeamViewer 15.6.7

    Best Regards,

    Jocafi

  • Kylian01
    Kylian01 Posts: 31 ✭✭

    this problem is not only un Ubuntu i have it on

    Arch
    Manajro
    Ubuntu
    Debian
    Fedora

  • This works for Ubuntu 20 And Teamviewer 15.


    @bobgutierrez wrote:

    <TL;DR>

    sudo gedit /etc/gdm3/custom.conf

    Uncomment this line in custom.conf file:

    WaylandEnable=false

    and Reboot.


     

  • dactil
    dactil Posts: 1

    Worked like a charm, you saved my day! Thanks.