teamviewer.com link icon
or
Ask The Community

Mac OS 10.14 no keyboard on remote side.

On new Mac OS 10.14  there is no keyboard control on remote side.  Both of my machines are running the same Mac OS 10.14.  Was running fine before update.

Comments

  • scujas
    scujas Posts: 2
    Same here, any solution for this?

  • As far as I can tell, it's due to security settings on the client side... Problem is, I haven't been able to find a way to approve teamviewer control, prior to logging in.  I tried logging in from my phone, while sitting at my 10.14 machine, it asked me to approve a few things, but still didn't work.

  • gibhenry
    gibhenry Posts: 1 ✭✭

    TeamViewer Mac and iOS will connect to my remote, but the keyboard doesn’t work:  I cannot type my user/pass on the remote machine.  Sometimes the credentials are already filled in, but clicking the right arrow or using the enter key doesn’t log in, and text is not selectable.  Curiously, the digital clock on the login screen perpetually reads 2:49AM.  

    Both ends running Mac OS 12.6.  The local Mac is running TeamViewer 13.2.26559, iPhone is 13.2.111907CL; the remote machine should be the same Mac version, or perhaps one version earlier (can’t tell!).

    I recently turned on IPv6 at the local end, but it’s hard to imagine that would affect the keyboard only.  Any insight?

  • Ozzy80
    Ozzy80 Posts: 1 ✭✭

    TeamViewer Mac will connect to my remote (android) , but the keyboard doesn’t work:  I cannot type my user/pass on the remote machine.

  • YoSappy
    YoSappy Posts: 4 Newbie

    I cannot Login either. I'm running MacOS Monterey Version 12.5.1 & TeamViewer Version 15.33.7 on both Macs; but, when I connect, which works just fine, the Keyboard Typing of the Login Password does not work. I've tried changing many settings, restarting, etc.; but, nothing works.