Connection from Windows 10 to MacOS fails after update to High Sierra from Yosemite

Hello everyone!

I use a teamviewer to help my friend with her computer. Recently we started to have connection problem. 

My computer is running Windows 10, her is running MacOS High Sierra (previously was running Yosemite), with unattended access set up. Both computers are running latest versions of Teamviewer (checked couple ours ago).

Earlier I was able to connect to her computer (even if it was locked or she was logged out), to wake it up, to log-in, to do something and lock it back with no problem. After update to High Sierra - it is not always possible.

If her computer is active (she is logged-in and working) - I can easily connect, help her and disconnect after. If her computer is "freshly-locked" or "freshly logged out" (less then 10-15 minutes, didn't try to wait longer) - I still can connect. If she is logged out more then several hours ago - connection results in error "Connection could not be established" rigth after "Authenticating..." step.

What is wrong and how to fix it?

P.S. I was thinking her computer goes to sleep after a while after log-out and it results in shuting TeamViewer down , but her Mac is prohibited to go to sleep.

P.P.S. Also tried to remove TeamViewer and reinstalling it with freshly-downloaded installers - still the same issue.