Easy Access with AD Service Connection Point

After tried without success to use the assignement tool which I cannot make it to work at startup throug a GPO startup script, I used Active Directy Service Connexion Point to Assign  account to computers (host installation).

But this way the Easy Access is not granted by defautl

It looks like TeamViewer Policies are not able to activate Easy Access (https://community.teamviewer.com/t5/TeamViewer-General/Policies-Secure-unattended-access-to-devices-Grant-easy-access/m-p/3467#M1061).

How to to it automatically on all our computers?

Using version 12 by the way.



  • Julia
    Julia Posts: 290 Staff member 🤠

    Hi SupportS2L,

    You can only deploy the easy access with the Assignment Tool - due to security reasons it is not possible create a policy for this or roll it out via .reg file

    What was the problem with the assignment tool on the machines?


    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • SupportS2L
    SupportS2L Posts: 4 ✭✭

    OK, I understand that Easy Access activation is available with Assignment Tool only.
    When I run the assignment with a batch as startup script with the following line:

    TeamViewer_Assignment.exe -apitoken **** -allowEasyAccess -wait 30 -verbose -datafile "C:\Program Files (x86)\TeamViewer\AssignmentData.json" >  C:\Windows\Temp\TeamViewerAssign.bat.log

    I have this

    2018-07-19 14:58:36 WebAPI: GET 'devices?remotecontrol_id=rXXXXXXXXXX'
    2018-07-19 14:58:36 => Assignment failed with:
    Get https://webapi.teamviewer.com/api/v1/devices?remotecontrol_id=rXXXXXXXXXX: dial tcp: lookup webapi.teamviewer.com: getaddrinfow: Une erreur irrécupérable s'est produite lors d'une recherche sur la base de données..

    Which means: "irrecoverable error occured while searching in database".

    I d'ont even see the packet going out on our firewall.

    If I run later the same command with a logged in administrateur with highest privilege the assigment is successful and I can see the packet going to the API on our firewall...

    I tried also with a more complex powershell script ran with a scheduled task at logon with a dedicated user that is local admin but I encounted invalid token error.

    I find this tool quite hard to use.

  • Bonjour SupportS2L,

    As-tu trouvé une solution concernant ce soucis, je suis dans le même cas c'est super embétant !
    Bonne journée