Remote screen freezes after a few seconds

When attempting to connect to my home computer from school it makes the initial connection and then works for a few moments and then as soon as I do something more than a message received on Skype which cause an update on the screen -- it will just freeze. I'm able to still send keystrokes but no-matter what I do it will not un-freeze. Disconnecting and reconnecting resolves this but then it's just back to the start; a rinse and repeat process. And after a while it will just hang on initializing. Connecting outside of the school will work perfectly fine. I've attempted reinstalling both instances of TeamViewer and attempting to use Proxies/VPNs  (so far only on the client). Is this a known issue and if so is there a fix and or anything I could try to resolve the problem. It is very annoying that I cannot remote desktop into my home computer. Other solutions are just not TeamViewer


  • Try solution in this post (disable udp in teamviewer advanced settings)

  • I had the same problem and found that it was due to my intel driver that I was using when I installed arch plasma.  To fix I installed vesa drivers and removed intel drivers:

    $ sudo pacman -S xf86-video-vesa
    $ sudo pacman -Rs xf86-video-intel
    $ reboot

    0 issuses after that 

  • The same problem here from my Win10 PC with three customer PCs, all Win10. Disabling UDP fixed it. Why is UDP the "recommended" option when it causes problems for so many users? Disabling the recommended option makes me somehow feel I would now use the less performant option (but for the full price :-( ).

    I would be willing to provice tests and log files if the Teamviewer team is interested!

  • gba
    gba Posts: 1

    where do I find udp?  I went to advanced settings but cannot seem to find anything thqt resembles udp.

  • I hope you've managed to fix this issue, but if you haven't the fix for this is very simple and it disappoints me that nobody from TeamViewer Support has bothered to rectify this in this post or for any of the other forum posts.

    Older versions of TeamViewer didn't have a hardware acceleration tick box in the settings, instead you had to enable/disable in Windows which is a bad idea, because doing so affects other applications on the computer.

    In recent years, applications TeamViewer included have been including a toggle box that allows you to enable/ disable it for that particular application.

    The Fix
    Anywho, to fix this problem open TeamViewer, go to Extras>>Options in the left pane select "Advanced">>Show Advanced Options, scroll down to the bottom of Advanced Options, below the "More" heading you will see a tickbox labelled "Disable Hardware Acceleration". If this option is unticked, tick it. If it's ticked, untick it.

  • kode54
    kode54 Posts: 17 ✭✭

    I still experience session freezes from Linux server to Windows client after a few seconds, even when the logs show that it's a TCP session. I can send the logs, but I know that TeamViewer just isn't interested in supporting anyone who isn't paying for their service.

  • steven9
    steven9 Posts: 1

    Check if you have 'record partner's video and ...' checked under 'Remote control'
    If so, uncheck that. (seems as it's default on) 
    I think this solved my similar problem with windows client and raspberry pi host which got unresponsive after some seconds.