teamviewer.com link icon
or
Ask The Community

Office 365 Shared Mailbox As Own Email Server

Hello,

It seems that including IMAP credentials to use an Office 365 shared mailbox as own email server do not work.

The same details work on other third-party applications that we use. 

The check details button even validates that the details are correct but they cannot be saved as the email address form on the page has a constraint that does not see it as a valid email address.

Example

Username: [email protected]\SharedMailboxName

Password: myuser password

Ideally, it would be great if the form validation could be changed to allow a username in this format as it passes connection tests. What would also be needed in order to use our own SMTP server to send would be the ability to supply a different username and password for the SMTP server.

Example

username: [email protected]

password: mypassword

I have come across this same issue before with other third party apps but they have been solved quickly so I have every confidence that servicecamp will make the changes required also. It's a quick and easy change request that will help out all other Office 365 and Exchange users with shared mailboxes ( Every Corporate client will most likely use these ). The ability to authenticate this way is already there. Its just being restricted by form validation and the lack of an input field to specify a different username and password for SMTP. 

 

Comments

  • DDawg
    DDawg Posts: 1
    I have the same problem with integrating my own e-mail server (Office 365) with a service e-mail account. There doesn't seem to be an option for TLS encryption for incoming which is required for the connection to establish. There is an option for TLS/StartTLS on outgoing e-mails only.
  • Yervand_PM
    Yervand_PM Posts: 102

    Hi 

    We have passed your feedback to our back-end team for further review. As soon as we get update we wil inform you.

     

     

     

    Yervand
    Product Owner
  • Yervand_PM
    Yervand_PM Posts: 102

    Hi 

    We have removed validation for IMAP username field so feel free to configure your shared inbox.

     

    Yervand
    Product Owner
  • HOS
    HOS Posts: 1

    Hello! I have a problem with "Office 365 Mailbox As Own Email".

    Configuration is fine and connection test result is "OK". But system is not generating tickets. POP3, IMAP - no difference. Why?

  • Hi 

    Could you please try to rename your shared folder name to "inbox"

     

     

     

    Yervand
    Product Owner
  • I have just subscribed to TeamViewer with ServiceCamp and as of yet have not been able to integrate our own Office 365 Email Server. Everything comes up as fine when checking the connection but no emails are getting through to be converted to tickets?

    EDIT: Outgoing emails from ServiceCamp now send via the correct Email address, however no incoming messages are being received?

    Any ideas?

  • LucasH
    LucasH Posts: 2

    We had the same problems and after try-and-error and only sporadic working we decided to forward all incoming eMails to [please do not post email addresses].

    This has some advantages:

    Incoming eMails will be received at servicecamp 100% sure
    Incoming eMail without the ticket number aren't forwarded, so our inbox of the shared mailbox is normally empty, except of eMails without ticket-number (Exchange Mailflow Rule)

    Sending from Servicecamp over SMTP (Exchange Online) is absolutely no problem if you set as follows:

    Incoming Mail Server (IMAP):
    Host: outlook.office365.com (993 - SSL enabled)

    Outgoing Mail Server (SMTP):
    Use own outgoing Mailserver
    Host: smtp.office365.com (587 - STARTTLS)

    User Name:
    just the eMail-Address of the shared Mailbox without any Backslashes(!)
    Password:
    It seems, that if you change anything on the setting, you have to paste your password again! We spent hours to see, that nothing is working until we pasted the password again!!

    .

  • LucasH
    LucasH Posts: 2

    Update: We found that again some incoming eMails got lost (neither attached to the cases nor found in spam). So we decided not to forward eMails to Servicecamp anymore. Rather we keep them in the Shared Mailbox and set Servicecamp to Poll the eMails via POP. Retrieved eMails this way are deleted, so the inbox should always be empty a few minutes after mails are received. I think this is currently the best way, as we cannot risk loosing incoming mails.

Sign In or Register to comment.