No Control of Keyboard and Mouse

b01marc Posts: 2
edited May 2023 in General questions

Hello all,

I'm running the most recent install of TV on two devices both running the most recent version of Mac OS X Mojave Beta. After install and logging in, I set all permission to "Full Access" to be able to remotely control either of the devices, and both are set to have unnattended access as well.

When trying to run and contro the other computer, I am able to see the others Mac desktop screen, but cannot control anything at all, only see the screen. This is the same on both computers, neither being able to control one another.

Please advise.


  • Hello

    I have the same problem using a raspberry pi 3. did you find a solution/big fix to this problem?

    thank you


  • not yet. Still waiting


  • Macservices
    Macservices Posts: 2 ✭✭

    I have the same problem.

    when I log into older operating systems 10.12.x or 10.11.x I can’t control the screen with the mouse or anything. I was able to last week.
    I am on 10.13.4 Apple iMac.
    Teamviewer 13.2 or 13.1
  • Alphacenturi
    Alphacenturi Posts: 3 ✭✭



    the answer is here:



    I also had to enable Teamviewer remote deskptop but everythinh up and running now.


    if you cnt follow the link go to Teamviewer to searhc community, put in "How to..." and the first rticle is abotu controlling a mac using is an apple problem that needs a secrity release


    All sorted! ;o)

  • FraMa
    FraMa Posts: 1

    It doesn't work for me.

    I'm using a Windows 10 pc and I'm trying to control an iMac (Mojave 10.14.3). I'm able to conntect to the iMac but keyboard and mouse don't work.  Yes, I granted access to TeamViewer on the iMac.


  • Macservices
    Macservices Posts: 2 ✭✭

    Yes, this is a security issue of 10.14.x.

    For TeamViewer to control the computer go to The Apple Menu>system preferences>Sercurity>Privacy>Accessabilty 

    Click the lock and put in the Admin password so the lock is open.

    If you do not see Team Viewer, add it and put a check mark. Now it will be allowed to operate the computer. This is security so 3rd party apps can not control the computer.

  • hrsalz
    hrsalz Posts: 1

    I am still not having any success controlling through remote setup. I can see the screen, but cannot control the mouse or keyboard. I am going from a MacBook running Mojave to an iMac running Mojave (both 10.14). All articles tell me to the same things I am already doing, but no luck yet. I have checked the TeamViewer and TeamViewer Desktop full access under the Accessibility tab in Security & Privacy. I have checked both boxes for Unattended Access in the TeamViewer app itself. It should have full control based on everything I have read. Any further steps I can try? Or should I do a reinstall of TeamViewer on my iMac?

  • Hello, did you manage to find a fix for this? We have run into this issue with MAC OS Mojave trying to connect to Catalina from both TeamViewer 14.7 and TeamViewer 15. Any help on this would be greatly appreciated.


  • tomascco
    tomascco Posts: 1

    I have recently started to have this same issue, and following the posted instructions on TV site yielded no positive results.

    Both laptop and desktop are running Mac OS 10.14.6. I have both Teamviewer app and Teamviewer_desktop approved in Full Disk Access. But I am still unable to control the remote computer.

    It's terribly frustrating paying full subscription prices and not being able to perform as advertised.

  • masterbeat
    masterbeat Posts: 4 ✭✭

    Experiencing same issue here, TV on Mac Mojave can't control TeamViewer on Mac Catalina.  Both on latest version 15, both have remote access enabled in security/privacy.

    Come on TeamViewer, you've got customers and people reporting this for weeks, no fix?

  • mbrun
    mbrun Posts: 1

    I was able to get it working using the Knowledge Base article in the provided link. Thanks!

  • Darjas
    Darjas Posts: 5 ✭✭

    I used the Knowledge Base article in the provided link and it is still not working for me. I have Mojave on iMac.

  • GiuLe
    GiuLe Posts: 1 Newbie

    It worked for me with a caveat.

    Permissions were already set correctly but not working. I set all permission off. Then i tested a new teamv. connection and i received on the machine the request to grant access for files, keyb and mouse. I followed the request and gave again permissions, and it worked. Probably some jam in the permissions that was cleaned with that trick.