link icon
Ask The Community

A Comunidade TeamViewer chega ao Brasil 🎉

Check out our brand-new Portuguese Community 👉 here 👈.

Mac stuck at log in screen



  • AK4IJ
    AK4IJ Posts: 8

    As far as I know there has been no update for this problem. I am successfully using TV12 after updating to Mojave on my iMacs. But beware that because of the "sandboxing " which Apple does, you will have to have someone on the other side to change your preferences to allow TV to access the remote mac.


  • edaza
    edaza Posts: 1
    Downgrading to version 12 worked for me as well. I had tried some of the above remedies but neither worked for me. I replaced TV version 13 to 12 on both my client and host machines, as well as disabled auto update. Hopefully v13 gets patched soon.
  • la79
    la79 Posts: 2

    Seems like an update was pushed out for Macs. However, the problem still persists. Any idea on when this is going to be fixed for version 13?

    Unfortunately, I can't downgrade all my machines to 12.

  • Bill_H
    Bill_H Posts: 11

    Yes, new version but same login failure problem.

    The good news, though, is that you can still get up to 15% off and a $200 Amazon gift card if you buy the business version of this software that is completely useless.

  • DaviCR
    DaviCR Posts: 2

    I gave up TV after this issue and switched to **Third Party Product**, which works perfectly in mac and has everything that I need (that was my case, it's not for all TV users).

  • Thank you, that does the job for me !
  • ae6dx
    ae6dx Posts: 9

    What did you use?

  • la79
    la79 Posts: 2
    All, it seems like TeamViewer 14 has fixed the problem. I just updated all my computers to the beta preview and it seems to be working correctly now.
  • ogoudron  answer, using keyboard instead of mouse

  • That worked for me, Thanks!!
  • SDB
    SDB Posts: 2
    I have the same problem. Workaround was working for a certain time. After 3,4 logins i finally got in. But now - no way. Time difference login Screen and RT is at over 14h. Accessability, Firewall all is set for TV to get in.
  • SDB
    SDB Posts: 2
    Thanks for that! but only works on 1 of my 2 Macs with TV.
  • Is it possible that only the problem Mac is running Mojave? If it is then you have to grant permission for the TeamViewer app to control the computer. If TeamViewer is set to run at boot or login, then you will also need to grant permission for TeamViewer_Desktop.

    See this article in the Knowledge Base:
    How to control a Mac running macOS 10.14 Mojave

  • rlojr
    rlojr Posts: 2

    Not sure this is a real fix, but it is working for me.  

    When you've logged in, press the first key of your user name.  Then input your password and press Enter.  I have no idea why that's working, but it has on the past few occasions.  Good luck.

  • After reading everyones issues I tried a combination of all the solutions.

    1/ I connected to the Mac and got a black screen.
    2/ Disconnected and reconnected and then I got the login window on the home screen.
    3/ The cursor was frozen in the login box but I clicked once in the login box and typed the password and enter.
    It logged in.
    Why cant they fix this?????

  • This just worked for me. Thanks!

  • Liro72
    Liro72 Posts: 1
    Just checking in again to see if the TeamViewer has made any progress on addressing this behavior since they're forcing us to upgrade past 12, the only version that doesn't have this problem.
  • mloboda
    mloboda Posts: 1

    Still have this issue on 14.2.8352. Any actions from "Action" menu do nothing. Guys, I've payed money for this soft, but can't use it without asking someone to wake up my iMac. Terrible

  • Natascha
    Natascha Posts: 1,356 Senior Moderator

    Hi @mloboda 

    Thank you for your post. 

    Can you please call our support team?

    They are happy to assist you in this case. 

    Thank you very much and have a great day.

    All the best,

    German Community moderator

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • @TopsAuto wrote:

    I to am having the same issue. I tried typing in my user's name password anyhow, and then it comes back to life again! Give that a try.

    This worked for me as well!!!

  • mailing
    mailing Posts: 5 ✭✭

    this worked for me:

    ssh via regular vpn, then

    launchctl stop com.teamviewer.desktop

    it will relaunch itself automatically. ofcourse you'll need to already have ssh and vpn working. I only use tv via incoming lan connections and prefer to handle the vpn myself. it works from other non-lan networks as long as it has ip connectivity.