teamviewer.com link icon
or
Ask The Community

Web page shows commercial, but the TV13 app still says it's free & won't work

Trying to sync to our corporate account.  I had a free TV11 on my PC.  I just upgraded to TV13, since that's what the corporate license is for.  I followed the instructions to connect to our corporate TV account, got the "device authorization email", added my PC as a trusted device.  Our company admin sees me in the user's list.  The web page signon shows me as "Corporate", but when I select a PC to remote into, it opens the TV13 app, which shows "Free license", shows the nasty pop-up, & won't let me connect.  Our admin hasn't seen this problem before now.  Something is working since I see the complete list of remotes in my TV13 app.

Others can connect to that remote PC, so it's just me having the issue.  How do I get the app to recognize the corporate account?

Comments

  • Esther
    Esther Posts: 4,112 Former Community Manager

    Hi @amartens

    Thanks for your post.

    Do get the TeamViewer software recognize your license, you need to sign in with your TeamViewer account to the Computers & contacts list: signin.png

    When being signed in, you should see your username (and image)  as well as your license on top.

    Best, Esther

    Former Community Manager

  • I am signed on with the same username & password.  I can tell that is correct because all the connections ported over to the app.

    What may have messed this up:  My TV11 was the free version w/ a different username/password.  When they setup my corporate account, they used a different email/password.  As soon as I logged into the app (now TV13) w/ the new username, all the corporate connections showed up, but it never showed a commercial license.

    It does show commercial in the web page & the admin sees me.

  • 1 more thing:  the web page shows corporate, but it also says I'm in a trial period for 5 more days

    "Your trial for viewing & checking policies on your devices will expire in 5 days.  Buy a TV13 license now"

  • Esther
    Esther Posts: 4,112 Former Community Manager

    Hi @amartens

    Thanks for the info.

    It sounds like you maybe have two licenses in your company.

    Can you please check with the company administrator (of the TeamViewer company profile in the Management Console) whether the correct license (TeamViewer 13 or TeamViewer subscription) is assigned to your TeamViewer account.

    Thanks, Esther

    Former Community Manager