Can not connect to Mac client unless user logged in

DerekErb Posts: 5

I am having this problem on every Mac client I need to connect to.

I am running TeamViewer 13.2.14328 and every client is running the same version as a supposedly unattended host.

In Preferences - General, on each client, the account is assigned to me and my company. In Preferences - Security, on each client, the "Grant Derek Erb easy access" checkbox is ticked and the Personal password (for unattended access) is filled in and works properly.

Even if they reboot the computer I have to wait until they log in to be able to do anything. I can connect to the computer and I see the icons of the user accounts ready to click on one to log in. But I can not click on anything; neither the user accounts nor the Restart / Turn Off links at the bottom of the screen.

The other symptom is that, again I can connect to the client, but I get a blank black screen.

In all of these cases I connect to the client with Log Me In, log in as a user on the client Mac, and then I can connect with Teamviewer. I have been looking in to replacing Log Me In on my client computers for a year now. At the moment I have to have BOTH running on their computers, simultaneously, in order to get TeamViewer to work correctly.

Not an option.

PS: I am posting this here as someone had a similar problem with a server host and that is now marked as solved. My problem is not solved.


  • I'm encountering a similar issue. 

    The other thing it's doing, is its freezing on the account screen after 60-75 minutes. I can connect to the partner computer, but I'm not able to click on anything on the screen. I notice the clock in the menu bar does not update. 

  • This is due to a bug in the latest version 13 of TV with the Mac. There are a number of other threads about this same issue. Given the lack of attention to this issue by TV, it seems the only solution is to revert to version 12 of TV. You must also disable auto update to prevent TV from re-installing the broken version 13.

  • digitalsteel
    digitalsteel Posts: 3 ✭✭

     Have the same problem - since updated to 13.2.14328!

    I had to install other remote App to display the login screen properly and accept my login inpout otherwise the screens in the remote Macs are dead - this is not good TViewer !!  please resolve!

  • Replying to my own question ... with a question...

    Anyone think this is fixed in TeamViewer 14?

    I am a bit reluctant to spend 1,000 more Euros for a new subscription when I'm not even sure that the product is going to work as needed.

    At the moment I'm paying both Log Me In and TeamViewer in order to be able to use TeamViewer properly.


  • Bill_H
    Bill_H Posts: 11

    Given their seeming lack of interest in fixing this serious bug, I certainly would not subscribe to TV.

  • GSIT
    GSIT Posts: 1
    Well, same problem in TeamViewer 14
  • digitalsteel
    digitalsteel Posts: 3 ✭✭

    this is due to increased security in MacOS Mojave and above
    Go to System Preferences>Security & Privacy > Privacy and allow access to TeamViewer / TeamViewer Desktop 

  • I tried going to Security & Privacy -> Privacy -> Accessibility and ticked the boxes for both TeamViewer and TeamViewer_Desktop. However, after a reboot, I still cannot connect until after a user logs in.

    Does anyone know anything else I can try to resolve this? I really need to be able to connect to the machine after a reboot.