teamviewer.com link icon
or
Ask The Community

Host only working if someone is logged in

I installed teamviewer 11 host on a Windows Server 2012R2. The teamviewer service is installed and running (under local system).

The problem is that it is only possible to use teamviewer as long as someone is logged in at the server (local or RDP). If no user is logged in and I try to connect teamviewer says that teamviewer is not runnung 

Best Answer

Answers

  • Dormi98
    Dormi98 Posts: 4

    Found the answer - but that gets me to the next problem. 

    I have to add my teamviewer account on the host to get this working.

    I see the server unter my computers in Teamviewer then and I can connect to the host no matter if someone is logged in or not. 

    The next problem is: How can my collegue connect to the host? - of course he is not using my teamviewer account. 

  • It's a community site - at least give the answer so that anyone following a link to this thread can also fix it!

  • I was looking for a solution to my problem which happens to be the exact same problem. I did not use my account to access the distant computer. I used the server ID and it worked perfectly! So I guess using an account is good, but not necessary!

    Just wanted to give my feedback and thank you for the trick! You helped me a lot :)

    Mohammed

  • I am having this problem on every Mac client I need to connect to.

    Even if they reboot the computer I have to wait until they log in to be able to do anything. I can connect to the computer and I see the icons of the user accounts ready to click on one to log in. But I can not click on anything; neither the user accounts nor the Restart / Turn Off links at the bottom of the screen.

    The other symptom is that, again I can connect, I get a blank black screen.

    In all of these cases I connect to the client with Log Me In and then I can connect with Teamviewer. I have been looking in to replacing Log Me In on my client computers for a year now. At the moment I have to have BOTH running on their computers, simultaneously, in order to get TeamViewer to work correctly. Not the best solution.

     

  • I have the same problem on Windows 7 only recently: if the remote user is logged in there are no problems in connecting with TeamViewer; if I lock the remote computer and I try to use TeamViewer for connecting, I see directly my remote desktop but I cannot use it.

    Any solution?

     

    - Lollo

  • What do you mean "cannot use it"?

    Did you use the correct host id? Note that there are 2 different IDs just as Katharina wrote. 
    I used the wrong ID first - using the hostID fixed my problem. 

  • For connecting, I just use an account in which I have "n" number of devices. All my computer are under the same account of course with different names. I use my account to choose the computer to connect (in this case my Windows 7 Professional) "locked" (I need to put in my password to use it) and when I try the connection I see the remote desktop but only ad guest, I can see the desktop and I cannot use it, it seems that I bypass the log in page.

  • This problem is different to mine. 

    I had the problem that I got a teamviewer is not running at the partners computer. 

    Nevertheless I think you should give it a try and connect to the Teamviewer server ID and not using you account. 

    Just set a password in the teamviewer settings, note the server id (About) and try to connect with this credentials

  • I just tried as you proposed but I didn't solve.

    I'll try again rebooting the computer when I will have the chance, because I cannot do it using remote control.

  • Thanks for the tip. I was struggling with this for ages!

  • Dhianefka
    Dhianefka Posts: 1

    Hi @Katharina ,

    Based on your information, is it possible to have 5 users connect remotely via TV to Windows Server 2019 in the same time? 

    If yes, would you please share the howtos?

  • Ale63
    Ale63 Posts: 1 Newbie
    edited May 10

    Same problem here, but when I use the Server ID now it doesn't tell me anymore that teamviewer is off, but it shows me a black screen and also clicking "Send Ctrl-Alt-Del" nothing happens. Trying to connect to a Server 2012 R2.

Sign In or Register to comment.