teamviewer.com link icon
or
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?


Download the new version and let us know what you think about it! 👉 Please click here 👈

Unable to change login password

Hello,

I have a user who is trying to reset his password, so that he can be assigned some devices.

When he goes to reset the password he gets the error "Sorry that was an error trying to process your request.

I have tried this in Chrome and IE but both give the same error message.

I also looked on the service status and can't see any issues reported.

 

Kind Regards,

Simon Robertson

Best Answer

Answers

  • JeanK
    JeanK Posts: 4,979 Senior Moderator

    Hi RobertsonS,

    Thank you for your message.

    If you have created your account on the 8th or 9th of November, you will need to delete your account and create a new one. Due to our server issues, some accounts have been damaged.

    In order to delete your account, please log in to your account on https://login.teamviewer.com/ click on your name in the top right corner and click on "Edit profile". Then, you will find find at the bottom "delete account".

    I hope this could help. If not, do not hesitate to contact us again.

    Cheers

    French Community moderator

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

    👉 Have you already tried out the new TeamViewer user interface? Do you want to give feedback? 👈
    ✅ GREAT - Go Ahead!

  • Hi,

    Thanks for coming back to me, this is an issue as the user is unable to login to the account but I do believe it was created on the 8th or the 9th of November 2018.

    Is there a workaround for this?

    Kind Regards,
    Simon