link icon
Ask The Community

TeamViewer 14 on Mojave - Grant Remote Control Dialog comes up on every launch

With TeamViewer 14 on Mojave, every time I launch it I am greeted with a dialog box coming up asking me to go into the Accessibility preference pane and allow TeamViewer to control my computer.

If you want TeamViewer to remote control this device, you need to grant TeamViewer accessibility permissions.

Screen Shot 2018-11-28 at 9.43.09 am.pngThe thing is, I don't want TeamViewer to remote control my computer - I only use it to remote control other computers.

I have gone into Preferences > Advanced > Advanced settings for connections to this computer and under Access Control I have set it to No incoming connections allowed.Screen Shot 2018-11-28 at 9.46.19 am.png

 This does not stop the warning from coming up every time I launch TeamViewer.

How can I stop TeamViewer from prompting me to change this setting every time I launch it?




  • I am getting the accessibility access on every launch of TeamViewer. I do not want to allow remote access to this device. I only use TV on this device to remote access other devices. 

    On this knowledge base page it says this should only havppen once, but that is not the case. I get the nag every launch. 

    Note: this dialog is only shown once for each app it refers to. It will not be shown again, even if you uninstall and reinstall TeamViewer.


    Screen Shot 2018-11-28 at 10.56.23 AM.png

  • Jeremy
    Jeremy Posts: 106 Staff member 🤠

    Hi @cdavis411 and @kaih,

    The dialog for granting accessibility permissions appears because the operating system (Mojave) requests this access to be granted when the TeamViewer application starts, even if TeamViewer is not actively receiving an incoming connection. It's simply an application permission used by the operating system.

    You can safely grant the accessibility access for TeamViewer, which will stop this dialog box from appearing again, while still blocking all incoming connections in TeamViewer.

    To block all incoming connections in TeamViewer itself, go to the TeamViewer Preferences, then to the Advanced tab, and within the section "Advanced settings for connections to this computer" change the Access Control setting to "No incoming connections allowed".

    This will block any and all incoming connections to this computer.

    TeamViewer Quality Assurance Engineer
  • kaih
    kaih Posts: 2

    The dialog box/window is drawn by TeamViewer, not by the operating system.

    It says "If you want TeamViewer to remote control this device, you need to grant TeamViewer accessibility permissions."

    I don't want TeamViewer to remote control this device, so I am not going to grant it accessibility permisions.

    It's useful to be warned about this once, but it's very annoying to be warned about this every time I launch the software. I do not want to give this permission to TeamViewer just to get a dialog box to go away, I want TeamViewer to respect my preference that I am not going to remote control this computer and not warn me about it every time I launch the software.

    I have already changed the Advanced settings for connections to this computer and set the Access Control setting to No incoming connections allowed.

    TeamViewer should check this preference when it's launched and if it is set to No incoming connections allowed then it should not present this warning dialog box.

  • Jeremy
    Jeremy Posts: 106 Staff member 🤠

    Hi @kaih,

    Thanks for your feedback on this topic. We're still looking into ways of improving how this works, and your feedback is helpful for that.

    You're right that the dialog itself is drawn by TeamViewer, however it is the operating system that is requesting the access to be granted, which is why we show the dialog.

    At the moment the only way to stop the dialog from reappearing is to grant the requested access to the operating system. I can certainly understand the logic behind why you wouldn't want to do this when you don't want to allow incoming connections. Please rest assured that it is completely safe to do so.

    I would also like to point out that the TeamViewer setting "No incoming connections allowed" is the only mechanism that actually blocks incoming connections. Mojave's new Accessibility permission actually does not block incoming connections at all - even if you don't grant the permission, it will still be possible for an incoming connection to be made to your computer using TeamViewer, and for the other person to view your screen (of course, depending on the other person having your TeamViewer ID and password to do so).

    Rather, the Accessibility permission only controls whether the other person can use their mouse and keyboard to control your mouse and keyboard. So if you don't grant the permission, the other person can still connect and see your screen, but won't be able to use their mouse and keyboard.

    Therefore, the only way to prevent incoming connections in their entirety - aside from not giving out your TeamViewer ID and password to anyone - is to change the TeamViewer setting for Access Control to "No incoming connections allowed". Therefore it's safe to grant the Accessibility permission to the operating system.

    And bearing in mind that the Accessibility permission itself is a new feature of Mojave. Previous versions of macOS didn't have this permission for TeamViewer at all, and yet TeamViewer was every bit as safe and secure on them as it is on Mojave.

    In any case, I'll pass your feedback on to our product management with regards to the frequency of the dialog appearing.

    TeamViewer Quality Assurance Engineer
  • newminds
    newminds Posts: 2

    I am paying a lot to use Teamviewer. Getting confronted with this popup on each launch when I am urgently trying to help a customer is not helping. 

  • Hi @Jeremy , any updates on this? The screen keeps me from helping a customer swiftly by turning up whenever I need to help someone. What is the idea of your product management team on this?

  • Hi @newminds,

    Did you install an update within the last year? The dialog currently looks like this:Bildschirmfoto 2019-09-12 um 09.23.01.pngScreen Shot 2019-09-12 at 9.46.58 AM.png












    But if you don't allow incoming sessions, the dailog shouldn't appear at all for you. I've just tested it and works with the latest version of TeamViewer. 

    Please always use the newest version, since the Product Management or in this case the product owner hear your voice and improved the product accordingly.

    Best, Oli

    Product Owner (Enterprise)
Sign In or Register to comment.