teamviewer.com link icon
or
Ask The Community

TeamViewer is not working after automatic installation of kernel in Ubuntu

I am using Teamviewer 14 in Ubuntu 14.04 LTS 64 Bit OS. Just now, the OS popped up with some updates and it has updated the kernel i.e., `linux-image` which I was using without any issues. Please note that Teamviewer 14 was working on this kernel with no issues. However, after the update, Teamviewer 14 stopped working. Below are the logs-

[email protected]:~/.local/share/teamviewer14/logfiles$ ll
total 16
drwx------ 2 ravi ravi 4096 Dec 29 01:28 ./
drwxrwxr-x 4 ravi ravi 4096 Oct 24 21:14 ../
-rw-rw-r-- 1 ravi ravi 153 Dec 29 01:28 gui.log
-rw-rw-r-- 1 ravi ravi 200 Dec 29 01:28 startup.log
[email protected]:~/.local/share/teamviewer14/logfiles$ cat gui.log
/opt/teamviewer/tv_bin/TeamViewer: error while loading shared libraries: libQt5X11Extras.so.5: cannot open shared object file: No such file or directory
[email protected]:~/.local/share/teamviewer14/logfiles$ cat startup.log
Init...
TeamViewer: 14.1.3399 - DEB
Profile: /home/ravi (ravi)
Desktop: DS: 'ubuntu' XDG: 'Unity'
XServer TTY: 7

ok (info)

CheckCPU: SSE2 support: yes
ok (profile)

I tried installing Linux home 3.13.0-164-generic but Teamviewer 14 still did not work. Below are the details of the current kernel-

[email protected]:~$ uname -a
Linux home 3.16.0-77-generic #99~14.04.1-Ubuntu SMP Tue Jun 28 19:17:10 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

I am wondering how do make TeamViewer 14 working?

Best Answer

Answers

  • I'm using Linux Lite 2.8 (Ubuntu 14.04LTS) and after the automatic updates via sudo apt-get update, TeamViewer no longer worked.  The prior version 13 worked just fine.  I ended up purging out all of my TeamViewer installations and then installed version 13 and it worked just fine again.  Then I upgraded to the latest version and nothing worked except the icon in the task bar, but nothing inside of it worked.

    I followed your suggestion to Downgrade using sudo apt-get install teamviewer=14.0.14470 and now everything works great!

    Thanks for the great Technote!

    Tenderfoot56

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!