Raspberry pi - image file to SD card - cannot establish a new ID on new device

Options
rik94588
rik94588 Posts: 1

I have a custom SD card image that I have created to fit a specific need.  When I re-image a new SD card and try and install Teamviewer on the new SD card the first Partner ID fills in the ID with the first ID established on my starting SD card.  I have un-installed Teamviewer on the Raspberry pi and have done a "sudo apt-get remove Teamviewer && sudo apt-get autoremove" command seems like it works, but when I reboot and re-install Teamviewer the first ID is back.  Any idea of how to generate a new ID for an imaged SD card?

Comments

  • ChristianCay
    ChristianCay Posts: 182 [Former Staff]
    Options

    Dear rik94588,

    Thank you for your post.

    When you clone an image with TeamViewer installed you will get a cloned ID.

    That's the reason why we recommend to install TeamViewer after an image is deployed.

    However, please try this commands to fix your issue. Please keep in mind that this steps will clear all TeamViewer settings and start with default values.

    sudo teamviewer daemon stop
    sudo rm -rf /opt/teamviewer/config/global.conf
    sudo teamviewer daemon start

    Then check if Teamviewer get a new ID by running the following command

    teamviewer info

    Let us know if this solution works for you.

    Have a great day!

     

    Best regards,

    Christian Cay

    Did my reply answer your question? Accept it as a solution to help others, Thanks.