link icon
Ask The Community

Windows 10: select programs do not display correctly

When using TeamViewer to remote to my PC: programs such as the Start Menu, Windows Photo Gallery, Windows Settings do not display correctly. (My PC: Windows 10, 64bit, Dell Inspiron 15 5570; and running the latest version of TeamViewer.)

The Start Menu's pinned items look fine, but the Programs list is all weird (see this link for image:; it also lets your scroll through the list somewhat, but it doesn't display the programs.

For Windows Photo Gallery, the program opens and looks normal, except the image file that's open never displays; it just states "Loading..."

For Windows Settings, some things you can access just fine, but when getting to a scrollable page, the scroll bar would scroll, but the viewable content would not change.

There are a few other programs that I've found that have issues very similar to this (like - the file opens and everything looks normal except that the image never displays; Minecraft - the launcher opens just fine, but after hitting "Play" it turns and stays completely white)

Then there are programs that do just fine: Windows Explorer, Paint, Windows Media Player, Calculater (Windows app), Microsoft Office 2016, Notepad, etc.

Maybe it's Hardware Acceleration issue, but Windows 10 doesn't allow for modification of Hardware Acceleration? Example, Firefox would open, but it was completely white until I disabled "Use hardware acceleration when available"; after disabling, no more display issues with it. BUT Office 2016 displays fine (as mentioned above), and I have not disabled hardware graphics acceleration.

I have also tested remote connection with Google's Chrome Remote Desktop, and ALL of these things behave EXACTLY the same way. Never had any issues with my Dell Inspiron running Windows 7 64bit (my old laptop -- not the one mentioned above).

Anyone have thoughts or run into this issue before?


Best Answer


  • bal
    bal Posts: 3

    Wow, TeamViewer wrote over the other products:

    **Third Party Product**

    **Third Party Product**

    **Third Party Product**

    **Third Party Product**

  • Hi

    I have the same problm after ver 14. When I connect to my MediaPC (without the projector on) I can not see the list of programs, and have probelm to scroll. But as soon I turn on the projector the probelm is gone.

    / Hans

  • Why is this thread marked solved?  The "solution" is no solution at all.  I can't keep my laptop screen open all the time just so I can connect via team viewer - I need TeamViewer to function correctly when the lid is closed.  Either some solution of something that can be disabled in Windows (since this affects more products than just TV), or some fix that works.  TV is severely crippled now that I've upgraded to Windows 10 on my remote computer.  Never had any issue with Windows 7, but now it's barely functional.  

  • Hello,

    as I have the same problem I wonder what the solution might be.
    Every hint was replaced with "3rd party solution".
    Very helpful...

    Thank and best Regards.

  • 527
    527 Posts: 1

    I've been searching FOREVER for a solution to this and, while it gives me a little relief knowing that tons of other people are experiencing this and it's not just me, I just can't accept that there hasn't been a solution yet. What's interesting to me is that I just upgraded a laptop to Windows 10 and it works PERFECTLY with the lid closed. So I have 2 laptops that are always closed, and I only use Teamviewer to remote in. One was on Win 7 and one was on Win 10 and the Win 10 was useless with Teamviewer. I recently upgraded the Win 7 to Win 10 and it works! Windows Settings scrolls correctly and shows content. ProtonVPN and Firefox (two applications that would only show white or black empty boxes) display correctly. So far, every application and window on this laptop displays the way it should. As far as I can tell, all graphics settings are the same on each  machine. Same video card, same drivers, same Windows version, no updates available for anything. 

  • Bren0man
    Bren0man Posts: 2

    It sounds like the same solution I mentioned in the following thread would be applicable here, too:

    To restate the solution here, simply plug a display emulator device into your display output, and this problem should be resolved. It's not an ideal solution, but it is a solution nonetheless, and has been working well for me. The one I've used can be found in the link below, but there are others available for cheaper that will probably work just as well:

  • I can confirm what bal is saying.
    I have two brand new computers; a Dell XPS desktop and a Dell XPS laptop. I installed the latest version of TeamViewer on both. If I remotely connect to either and the monitor is on/laptop screen is up, everything looks fine. If I turn off the monitor/close the laptop screen I have the same small start menu issue as bal.
    As I was frustrated with this I thought this would be a good time to try out another product. **Third Party Product** seems to be getting a lot of attention so I installed it on my desktop and laptop. It also has the same start menu issue (it is very small and unusable).
    One thing of note is that both the desktop and laptop have Intel integrated video as well as a dedicated NVIDIA GPU. I've tried experimenting with the setting to see if it is something that needs to be adjusted but so far I've had no luck.
    I am going to keep looking into this to see if I can find a resolution. Hopefully the TeamViewer (and other companies) are doing the same!

  • deden
    deden Posts: 1

    Any real solution foud yet?

    It's probably related to the fact that the Intel Graphics adapter (UHD 620 on my laptop) turns off when the lid is closed. Then, for example, the "Intel Graphics Control Pannel" throws an error "Unable to launch application. None of the connected displays are using the Intel Graphics Driver". Funny.

    So I don't know what is responsible for drawing the Windows, but it's not the Intel adapter (which is the only hardware graphics inside the laptop). Anyway, it's not doing a great job, as all metro-based apps (and many more) are broken.

    So, is there a software-based fix to keep the Intel Graphics adapter running with the lid closed? Or another software-based graphics adapter that would work in this situation?

    Still looking for a working fix!!

  • To fix this, you need to change what Windows does when you close the laptop lid (prevent power-off). This is a simple driver swap-out for the laptop lid hardware (not related to the graphics driver)  from the Windows default provided driver found within Device Manager.

    See here: 

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!